Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Your connection was interrupted A network change was detected.

  • Most times when my PC wakes from Sleep I get the following error for about five minutes in Opera, if I switch to EDGE I can browse the internet, this just effects Opera.

    Your connection was interrupted
    A network change was detected.

    I normally run with about 20 tabs open, I always close all apps before sleep, this has been happening for quite a while, I think it was worse with V49, and better with the last version but I'm seeing it constantly with this new version. I'm running the following

    Version: 51.0.2830.40 - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit (WoW64)

    Any ideas, I'm getting to the point of switching browsers as Opera is becoming too much trouble

  • For anyone seeing this issue too, I found if you disable "Predict network actions to improve page load performance" under "Privacy & Security" settings it seems to fix it.
    How do I raise this with the Opera team, I presumed that raising it on the forum would raise it with them but obviously not as no responses, I'm really disappointed that they expect their users to fix all the issues.

  • @spannell You shouldn't expect any responses from Opera when reporting an issue.

    Did you check with other browsers, if possible including a Chromium based one?

  • It is a normal problem that when you use the browsers such as Google Chrome, Opera etc to view one website, you may get the error of Your Connection Was Interrupted, A Network Change Was Detected. There are four ways you can try to fix it:

    1. Change another WiFi router to connect to your computer again if you have another one.
    1. Flush DNS cache. Open the command prompt with the administrator account, and type in ipconfig /flushdns, then press Enter.
    1. Change your Internet Protocol IPV4 DNS Address.
    1. Adjust your Lan Settings to uncheck the option of Use a proxy server for your LAN.

    And here is the tutorial with pictures you can follow it: https://windows10skill.com/your-connection-was-interrupted-windows-10/

    Wish this can help you.

Locked