Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Always] fetch complete message

  • I have to click the button "fetch message completely" each time, when I open a newly received message.
    My setting for using low bandwidth mode is off.

    If this is a bug, please fix this.
    If this is regular behavior, please add a checkbox next to the button to always fetch the message completely. (to remember the decision for future messages). Or put an option in the preferences.

  • How about in Account settings? Okay, it isn't worded that way, but it is there in the Incoming tab. When it says "Make all messages available offline" that means it fetches the complete message as soon as it checks for messages and then keeps it even if you later go off-line.

  • @pink-ink Just to let you know that Opera Mail stopped being developed at least five years ago.

  • POP or IMAP? If IMAP, as sgunhouse said, check the settings on the "Incoming" tab in the account's properties. As long as you don't have "low bandwidth mode" set or "do not download attachments" set, you shouldn't have to choose "fetch complete message". That should be the case whether you have "make messages available offline when I click them", "make all messages available offline", or "do not make messages available offline". But, things in Opera Mail (like search) will work better with "Make all messages available offline", so set that anyway if you haven't.

    If IMAP and none of that works, you can try deleting the IMAP account and adding it back it to see if that fixes anything. Or, you can close down Opera Mail, rename the "mail" folder (see "Menu -> Help -> about Opera Mail" for the location" and start fresh.

    If none of that helps, we'd need to know the mail provider you're using.