Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera default browser

  • @lord-tob But you see the button to make Opera the default browser but it doesn't work or you don't see the button at all?

  • Windows 10 has been known to interfere with non-Microsoft browsers being set as default (or inheriting such default status after a Win10 update)... so it's useful to know the OS version. Whether Opera itself is failing to show a set-as-default function button in its settings panel is part of trying to understand the problem. If the button is not present, something's messing up Opera; if the button is present, try using it. If it succeeds, then you should be OK; if not, then you may have to manually set opera to be the default browser using Windows' Default Program functionality. If Opera isn't listed under those Windows default program possibilities, it means Windows doesn't recognize the Opera installation as a registered program. The questions are designed to analyze and converge on a cause before trying the most optimal solutions... not providing answers only slows the resolution process.

  • All right, I'm trying to cover all of the asked questions:

    • I'm running Windows 10x64 and Opera 51.0.2830.26
    • The button to make Opera the default browser is present and opens the Windows Default Program menu (if I remember correctly the same does the install routine of Opera when it is finished)
    • Opera is not listed within the Windows Default Program menu, although I deinstalled, restarted, installed and restarted several times

    It does not matter if I use the small install package or the offline install package.


    Thanks for your efforts!

  • @lord-tob Thanks for the information. What it shows is that the Opera installation is properly contacting Windows for setting itself as default, but Windows is not showing Opera as available for the protocols associated with a browser. This is an annoying problem Windows 10 has occasionally had for all non-Microsoft browsers, particularly since the Fall Creator's Update.

    1. Use Windows own Search facility to select "Default Apps settings"
    2. Scroll down near the bottom of the "Default Apps" panel, click on the "Choose default apps by protocol" entry
    3. After the pause when Windows populates the list, you should see a list of protocols; scroll down to FTP, HTTP, and HTTPS in the list.
    4. Click on the browser listed for FTP; you should see a "Choose an app" list appear. If Opera is present, click on it. Repeat this for the HTTP and HTTPS protocol entries. If Opera is not present in the "Choose an app" lists, please report back here, since it implies the Opera installation is not being properly recognized by Windows as being capable of supporting these protocols.
  • Temporarily create another Windows user account (another admin account if that's what you're using now) and test with that. Does it work there?

    That'll tell you if it's just your user's registry settings or if all users are affected.

  • @blackbird71 Thanks for your advice. Opera is not shown in the "Choose an app" (by protocol) list.

    @burnout426 I'll check the registry settings from your reddit link later and report back. Thanks!

  • On developer 52, clicking on the button to make Opera the default browser works without needing to open the default applications dialog.

  • @leocg Cool, that worked. I think I'll stick with the developer version for now. Thanks a lot!

  • Same issue here!

    • Win 10 Home (version 1709, OS Build 16299.248)
    • Opera 64bit - 51.0.2830.34
    • "Set as default" button is visible and clickable

    Reinstalled yesterday, I can't set Opera as default browser.
    I would argue that is more an issue on the browser side than Microsoft, as I have other 7 browsers installed (Firefox, Chrome, UC, Opera Neon, Vivaldi, Yandex, Whale) and they all work well. I tried to reinstall one of them today (UC) and it appears in the default browsers list as expected.

    This is what I see in the "set default by app" menu:
    0_1518780605543_opera issue.png

    As you can see the browser icon does not appear and I can set opera as default only for HTML pages

  • Solved!!

    I cleaned the registry with Advanced SystemCare (see setup below)


    This fixed the issue, I am now able to set Opera as default

  • @pandorave Cleaning the registry did the trick. Thanks for posting!

  • @blackbird71 said in Opera default browser:

    About half way down the Settings list, you should see:
    "Default browser"
    "Opera is not currently your default browser."
    button box: "Make Opera my default browser"

    Are you saying the button does not work to set Opera as default, or that you don't see such a button?

    Also, what version/type of operating system are you using (Windows 10, etc)?

    1/the button does not work to set Opera as default.
    2/Operating Systeme Windows 10 Professionnal.

  • @schpountz What happens when you click on the button?

  • There is no button...

  • @schpountz Before you said that the button wasn't working and now you say that there is no button. Which answer is the correct one?

  • The correct answer is that "there is no button".

  • @schpountz Are you on Opera 51?

  • Opera 51.0.2830.34

  • @schpountz Did you try an Opera reinstall with a clean profile folder?

Log in to reply