Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to disable completely the Speed Dial?

  • Just like in Topic, How to disable completely the Speed Dial? I'm using a 45.0.2552.882 opera version.

  • @virox First, why are you using such a very old version? Current one is 51.

    Go to settings, enabled the advanced settings then go to browser > start page and check 'hide speed dial'.

  • Hi leocg, I don't have an advanced settings and according to the Android store I'm using the latest version, 45.1.2246:

    App store showing version number

    Are you on the beta channel, or am I not looking in the right spot? I've checked all the settings with sub-settings and can't find advanced.

    I'd love to be able to disable the speed dial as I'll occasionally open the browser to go back to something I was reading and instead it'll open a new speed dial page, closing the old one 😞

  • @scottgage As anyone can clearly see, this is the 'Opera for Windows' forum, so this discussion is about Opera for desktops and not about Opera for Android.

  • @leoI have Opera 52.0.2871.99 installed on a 64 bit Windows 7 Pro SP1 computer with i5 processor, 8 GB RAM.

    I want to disable Speed Dial. Here is what I tried:

    Settings/Basic

    On startup, open a specific page . . .

    Set to blank page (about:blank)
    

    Settings/Browser/Start page (Show advanced settings enabled)

    Hide speed dial is enabled
    

    Opera starts with blank page, but whenever I click on the "Start page" icon at the upper left of the window, the speed dial is displayed.

    Conclusion: Hide speed dial does not work

    Please fixcg

  • @ofcgk9 It seems that you are misunderstanding or maybe doing something wrong.

    Here I have Speed Dial hidden in settings and when I click on the Start page icon, it opens Start Page with Speed Dial hidden as should.

  • @leocg This kind of post is completely useless and should not be allowed. No reference is made to OS version or Opera version and to just imply the user is stupid and doesn't understand what he/she is doing or doing something wrong without offering alternative troubleshooting steps is completely unacceptable.

  • @ofcgk9 Sorry but I couldn't find any post in this topic that matches with what you are saying.

  • @ofcgk9 Do it this way.

    In addition to checking "hide speed dial", also check "hide search box". Then, uncheck "Show speed dial suggestions". Then, either set Opera to "open with startpage" or a specific page of opera://startpage. Then uncheck "Enable wallpapers" or add a wallpaper that's all white. Then, it'll be like about:blank except for the little easy-setup button at the top right of the page. To get rid of the easy-setup, you might be able to create a simple extension that uses css to hide it (when you launch Opera with --extensions-on-chrome-urls=true and set the extension to request the permission), But, Opera might block that.

    So, you can't make opera://startpage be about:blank without an extension that redirects from the former to the latter. Your best bet is to just hide everything on the start page to make it look like about:blank.

  • @burnout426 OK, this is an acceptable alternative, at least for the short term, thank you. I can live with only the "Easy Setup" button displayed. The problem needs to be fixed. I submitted a bug report (since there is no way for users to search the bug reports, I have no way of knowing if this bug has already been submitted)

  • @ofcgk9 There is no bug to be fixed.

  • @leocg As a moderator you are completely worthless and need to be removed from access to this forum.

    First, you insult the intelligence of a user posting to this forum without offering any alternative troubleshooting tips.

    Second, you are incapable of recognizing that Opera is NOT acting as it should relative to the "Hide Speed Dial" setting and therefore, there is, indeed, a bug.

    Shame on you. Get off this forum.

  • @ofcgk9 Opera is hiding Speed Dial as should, when such option is checked in settings.

    What you see when you click on the four squares icon is the start page, which contains speed dial, news, easy setup button and so on.

    Also, Opera, like some other browsers, doesn't allow you to set a home page that will be loaded every time you open a new tab

    So, there's nothing wrong.

  • If you want to try an extension method to do what you want, you can try this:

    Set Opera to "open with startpage".

    Create the files in a folder named "Hide Speed Dial":

    manifest.json:

    {
        "name" : "Hide Speed Dial",
        "version" : "0.1",
        "description" : "Hide Speed Dial",
        "permissions": [
            "tabs"
        ],
        "background": {
            "scripts": ["background.js"]
        },
        "manifest_version": 2
    }
    

    background.js:

    var blank = chrome.extension.getURL("blank.html");
    var start = "chrome://startpage/";
    
    chrome.tabs.onCreated.addListener(function(tab) {
        if (tab.status === "complete" && tab.url === start) {
            chrome.tabs.update(tab.id, {
                url: blank
            });
        }
    });
    
    chrome.tabs.onUpdated.addListener(function(tabId, changeInfo, tab) {
        if (changeInfo.status === "complete" && tab.url === start) {
            chrome.tabs.update(tabId, {
                url: blank
            });
        }
    });
    

    blank.html:

    <!DOCTYPE html>
    <html>
        <head>
            <meta charset="utf-8">
            <title>about:blank</title>
        </head>
        <body>
    
        </body>
    </html>
    

    Then, goto opera://extensions, switch to developer mode, click "Load unpacked extension" and point it to the folder.

    Notes:

    • Using blank.html instead of the real about:blank because the former loads faster and leaves the address field empty so you can just type.

    • Since this is technically a redirect to the page, you'll see that the back button is lit up. Just ignore it. I don't see a way to avoid that except for closing the tab and opening up a new one, but that might look funny/noticeable.

    • If you click the start page button on the address bar (as opposed to clicking the new tab button) or type opera://startpage in an existing tab and press enter, the address field won't be focused when the blank page is loaded. Not sure how to fix that at the moment.

    • If you do the previous note, if you want to get back to the page you were at before clicking the startpage button, click and hold on the back button and choose that last page. If you just click back, it'll go back to Opera's real startpage and then redirect again to the blank page.

    Anyway, have fun with it if you want.

  • Now, instead if you want to hide the easy-setup button, do this:

    Create a folder named "Hide Easy Setup". In it, put the following files:

    startpage.css:

    body {
        display: none !important;
    }
    

    manifest.json:

    {
        "name" : "Hide Easy-Setup",
        "version" : "0.1",
        "description" : "Hide Easy-Setup",
        "content_scripts": [{
            "matches": ["chrome://startpage/"],
            "css": ["startpage.css"]
        }],
        "manifest_version": 2
    }
    

    Then, modify Opera's shortcut to launcher.exe so that the command is like this:

    "C:\Program Files\Opera\launcher.exe" --extensions-on-chrome-urls=true
    

    Then, load the unpacked extension (see previous post for how). Just note that if Opera is ever launched without --extensions-on-chrome-urls=true, Opera will remove the extension on you and you'll have to load Opera again with that option and then load the unpacked extension again.

    Then, the speeddial page will be white AND empty.

    I think if there was an option to hide the easy-setup button and make the whole startpage white, that'd help a lot.