Linux Mint Adobe Flash

  • Hello! My system is Linux Mint 18.3 (x86_64; X-Cinnamon) and Opera 51.0.2830.26 Stable. This is a new installation on my notebook. I cant enable Adobe Flash Plug-in. I visit https://helpx.adobe.com/flash-player.html to check flash. And nothing happens. I can see only a banner that says "Click to enable Adobe Flash Player". I'm clicking on it and nothing happens. Also, I right click on it and select "Enable Flash". And there is no any reaction. Flash doesn't work. Last week I tested Linux Mint and Opera on that notebook. Everything was fine. Flash worked well. Now, the difference is that I replaced HDD with SSD, and installed new OS. I think that Opera's version changed to 51 from 50 since that. Adobe Flash is preinstalled in Linux Mint. It works fine in Chromium and Firefox. The only problem is Opera. How I can enable it? May be I can check some permissions for flash files or something else?

  • I think, I've sold it. I reset the browser settings to default. After that flash is working fine. I found that the problem was in synchronization with Opera account. This account was made on Xubuntu 32-bit and Opera 45. After synchronization Adobe Flash stops working on my Opera 51 Linux Mint 64-bit.

  • Having the same problem with Ubuntu 16.04.

    Running Opera 51.0.2830.26 - Opera is up to date. Stable. System: Ubuntu 16.04.3 LTS (x86_64; Unity)

    Some sites keep saying Flash needs to be installed or enabled. Tried doing both and nothing happens, videos still refuse to play. Any help on what needs to be done to correct this?

  • @pindos Adobe flash does not support any Linux distro, they quit supporting Linux about 5 years ago.

  • Wrong, sort of. They stopped for several years, but they started back up. See https://get.adobe.com/flashplayer/otherversions/

  • @tomiki You are wrong. You can visit Adobe website and download flash for any browser for Linux.

  • @pindos said in Linux Mint Adobe Flash:

    @tomiki You are wrong. You can visit Adobe website and download flash for any browser for Linux.

    Tried doing that with Opera 51.0.2830.26 - Opera is up to date. Stable. System: Ubuntu 16.04.3 LTS (x86_64; Unity) and Flash still doesn't run!

    What's funny is I have a couple old laptops running Ubuntu 12.04 and 14.04, that still have Opera 42.0 and Flash and videos all play fine!
    However VPN on Opera 42.0 won't connect at all.

  • Opera 51 introduced a setting that is not available in chromium, i.e from upstream: to allow flash on all sites. Old opera versions used to have this as well. Chromium does not run flash on sites unless the user allows it to.

    To enable the setting in opera, go to settings > websites > flash > and select allow sites to run flash.

  • @jimunderscorep said in Linux Mint Adobe Flash:

    To enable the setting in opera, go to settings > websites > flash > and select allow sites to run flash.

    Done that and Flash still won't play whether 'Allow sites to run Flash' or 'Ask first before allowing sites to run Flash' (recommended) is clicked on .

    alt text

  • @cybrsaylr said in Linux Mint Adobe Flash:

    What's funny is I have a couple old laptops running Ubuntu 12.04 and 14.04, that still have Opera 42.0 and Flash and videos all play fine!

    Do you have synchronization of your new Opera 51 with this machines enabled? I mean the Opera account. I've said already that when I enabled synchronization in Opera 51 with my account, Flash stoped working. The only thing I have to do is to reset Opera settings. After that flash is working fine. That settings were made with Opera 45 on xubuntu 32-bit.

  • One of the options for Sync is Settings - maybe disable that?

  • @cybrsaylr
    You are right, it does not work as it is supposed to. Blame opera 😞
    I have all my browser set to click to play since... since click to play was first introduced, like 7+ years ago. Firefox literally f*ed it up on version 24 though.

  • @pindos said in Linux Mint Adobe Flash:

    @cybrsaylr said in Linux Mint Adobe Flash:

    What's funny is I have a couple old laptops running Ubuntu 12.04 and 14.04, that still have Opera 42.0 and Flash and videos all play fine!

    Do you have synchronization of your new Opera 51 with this machines enabled? I mean the Opera account. I've said already that when I enabled synchronization in Opera 51 with my account, Flash stoped working. The only thing I have to do is to reset Opera settings. After that flash is working fine. That settings were made with Opera 45 on xubuntu 32-bit.

    No I believe synchronization is not enabled for Opera 51.
    Going into Preferences > Browser > Synchronization, shows I have to sign in. So I assume Synchronization is not enabled.

    Until this Flash issue is fixed I have been using Vivaldi 1.14.1077.50 (Stable channel) (64-bit) browser as backup. Vivaldi plays every video and Flash thrown at it so far.

  • I was having similar problems and installed 'pepperflash-nonfree' in an ubuntu based system and it solved my problems regarding flash. I also have 'flashplugin-installer' installed. I think pepperflash relates to chromium based things such as Opera......

  • @plumtreed

    Well you have better luck than me.
    I have both 'pepperflash-nonfree' and 'flashplugin-installer' installed and Flash still doesn't work on some sites.

  • Flashplugin-nonfree installs the npapi version of flash which is completely useless and unsupported by chromium based browsers like opera. Keep it installed only if you have firefox or some other unknown browser than can use it.

    Moreover, if you are on ubuntu or on any of its derivatives, there is also package adobe-flashplugin from canonical's partner repo. Install that and you will get both versions of flash (npapi and ppapi) and remove both pepperflashplugin-nonfree and flashplugin-nonfree.

  • @jimunderscorep .......thanks for the tip, installed 'adobe-flashplugin' as suggested and in a quick test it works as you say, that is, after reactivating flash in Firefox.

    In Opera, I need to go into the menu to trigger the 'allow flash' selection periodically......it seems to default to the 'Ask to' selection but I never get asked.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.