Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to disable the private browsing splash screen?

  • alt text

    I mean this because the button just simply doesn't work.
    Is there a flag for it in opera://flags or something?

    Thanks.

  • hello?
    how do I fix it?

  • @whatduck22 Please wait at least two days before bumping a topic, specially your own.

    Did you follow the steps mentioned on the instructions?

  • Hello

    I actually have the same problem. I didn't follow instructions due to simple fact that I have new installation of Windows and new installation of Opera. No extensions were installed when problem arised. Every time I launch Opera I have this screen, and I checked the box multiple times to no effect. I have a shortcut set to always launch Opera in private mode.

    TIA

  • @yanc75 you need to open Opera with a normal window so the setting can be saved.

  • The checkbox has no effect for me no matter what. Has it ever worked for anybody? Maybe it's not implemented yet. If it used to work, I'm not sure what setting it uses. It doesn't seem to modify the preferences file at all (at least not immediately. Maybe on shutdown though).

  • @burnout426 it definitely worked before.
    I have the same version on a laptop and the screen's not there but I think an update broke it, it worked before when they first introduced it.

  • I've found a workaround:

    Using the ODev it works and you can copy the node to the OStable.

    0_1514396467118_2017-12-27_182240.png

    It's located at Preferences file, inside Profile folder:

    • OperaHelp > Find Solutions

    --

    I've used JSonEdit - easier than the Notepad -.

    If you use a Test version of ODev, just copy the node, if not:

    Create on the root the Child / Object .

    • private_mode

    Then, another one with it's setting / boolean:

    • welcome_page_enabled: false

    And save.

    --
    Use the Screenshots settings.

    0_1514396547549_2017-12-27_183051.png

    0_1514396554166_2017-12-27_183119.png

    --
    Important:
    Do a Profile folder back up before proceed.
    Opera has to be closed before editing any file.


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Opera Test profile | Opera Back up LinuxMacWin

  • @burnout426 It worked fine for me last time I've checked.

  • @zalex108 you're amazing!
    it works now, I just checked on my laptop and it does indeed have this node, so it must be broken since previous update and it doesn't get updated.

  • xD

    馃憤
    If they are on the same version, who knows...

    Sometimes, offline installer can fix some problems, if not, you can try using this method.

  • @zalex108

    Thanks man - your advice was correct, worked like a charm.

    For some less advanced users you may however give a hint where the heck is Preferences file located 馃檪

  • @yanc75 said in How to disable the private browsing splash screen?:

    For some less advanced users you may however give a hint where the heck is Preferences file located

    Well...
    In the Opera Help page

    • OperaHelp > Find Solutions

    appears how to find the profile and an explanation about every important file.

    Maybe, the only hint would be:

    • %AppData%

    But that just works for Windows users.

  • @zalex108 thank you so much 馃檪

  • @zalex108

    I had no problem with that, found it easily.
    However on daily basis I interact with users with little or almost no experience in computers, and because of that I learned to give advices step by step like i was dealing with morons 馃檪
    I found your advice easy to implement, but if I, for example, would give it to my workmate I probably would find her banging her head on the wall 馃槈

    So, if you want to be sure your advice reaches its target, be sure to give it the way any moron would understand.

    Yanc

  • @lyricsraag said in How to disable the private browsing splash screen?:

    @zalex108 thank you so much 馃檪

    馃槈 馃憤

    @yanc75 said in How to disable the private browsing splash screen?:

    However on daily basis I interact with users with little or almost no experience in computers, and because of that I learned to give advices step by step like i was dealing with morons

    I usually use both ways, it depends on the question.

    xD
    On/Off button