Flash 'Click to Play' - how to get rid of it?

  • I have been using Opera for years and loved it. I play a flash based game (My Brute) and yesterday it was working perfectly. Today the site loaded but no images. In previous versions in the settings there were four options, now there are only two - Ask first, or Block. I have it set to Ask First, and it would work, but now it has an annoying 'click to play' screen over the image and there seems no way to remove this as there was in earlier versions.

    I don't get why, when you have a lovely browser which works perfectly, you CHANGE IT, so that it is now absolutely useless to me. Very sad indeed. I have had to change to Firefox which works OK but just doesn't look as nice.

    Is there any way to remove the 'click to play' annoyance?

  • Settings > Flash >> Add site

    or

    Site Settings Sidebar extension


    Windows 10 (x64) | Anniversary Update
    Opera Stable · Beta · Developer

    Test profile | Back up Linux · Mac · Win

  • Thank you for the reply, but I already have Flash enabled. The problem is the 'click to play' which it seems there is no way to remove.

    I have heard that Chrome, so also Opera I assume, is stopping its support for Flash, but it would have been better if they had simply left the settings options as they were in older versions, so that 'click to play' could be disabled.

  • 'Click to play' was removed in Opera 49. However due to Chromium be removing support for Flash, you need to allow or block Flash content every time you try playing it on a site for the first time.

  • @leocg

    Well - all I know is that the 'click to play' screen comes up in the game I play on every image, on every page, thus making the game unplayable in Opera. I am now using a different browser. Sad, but not much I can do about it.

    Thanks for the replies.

  • @efte You can try this workaround for now if you want.

  • @burnout426 Thanks burnout426. Looks a bit tricky and for now I am using Avast browser to play MyBrute, and that is (so far) working fine. I have saved your instructions just in case something goes wrong with Avast.

  • Just had a thought! My Surface Pro on/off switch has been broken for a couple of months so have not been able to use it. Hoping to get it fixed this week.

    Opera was working fine on that. Is there any way to stop Opera from updating to avoid this problem happening again?

  • @efte Try renaming the autoupdater executable in Opera's installation folder.

  • @leocg As simple as that! Wow! Many thanks. I will do that and hope it works. It will be so nice to get back to Opera. :smile_cat:

  • This post is deleted!
Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.