Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera updated to 49 and now having flash player problems

  • Update: Did some digging and found a way to back up everything and uninstalled Opera and reinstalled onto my laptop in a different folder; also updated flash. Just like with the stand alones I did, the exceptions worked without restoring my stuff. However, when I restored everything, the problem returned. So, it's definitely a bug somewhere in my profile. โ˜น Problem is I don't know where in the profile. It's not any of my extensions because I still have the problem with ALL of them disabled. I have a suspicion it may be the preferences file in my profile folder, Deleting that particular file erases EVERYTHING except History, Bookmarks, and Sync Data, but I really don't want to have to manually download ALL of my extensions and re-add the Speed Dials, Speed Dial background or whatever else the Preferences file handles for one stupid mistake the devs made regarding flash since . ๐Ÿ˜’ If I can't find an acceptable solution, I just might switch over to Vivaldi once it goes over to Android. I really need a browser that's reliable and can sync with Android. Firefox is out since, it's another piece of crap on android.

  • Not sure. But, try this while Opera is closed:

    In the Preferences file, select and delete all the contents of the "site_engagement" block so that it looks empty like in the following.

    "sensors":{},"site_engagement":{},"sound":{}
    

    Do the same for this particular "plugins" block (it's the one for the exceptions).

    "plugins":{},"popups":{},"ppapi_broker":{}
    

    Do the same for "permission_autoblocking_data".

    "password_protection":{},"permission_autoblocking_data":{},"plugins":{},"popups":{},"ppapi_broker":{},"prompt_no_decision_count":{}
    

    Do the same for "media_engagement".

    "important_site_info":{},"javascript":{},"media_engagement":{},"media_stream_camera":{},"media_stream_mic":{}
    

    Then start Opera, add http://*, https://* and file:///* to the Flash exceptions and try things out.

    You can clear just one of the blocks in the Preferences file at a time if you want to try and pin down the minimum of what fixes the problem.

    Back up your preferences file first though.

  • @burnout426 No go. โ˜น I deleted everything I could find in the Preferences file and flash still won't work. It didn't even delete the exceptions so I'm guessing it wasn't that file after all. I'll be using Vivaldi for anything with flash from now on since flash still works with that browser.

  • @slytheringirl Hmm, there's stuff in the "Local State" file that relates to Flash. You can try renaming that to see if it helps. Or, maybe it's still in the Preferences file. Renaming it will tell you that or not. You could rename it back if that doesn't help or back up the whole profile folder before testing. Maybe the preference that's causing issues isn't obviously-named.

  • @burnout426 Thanks for all your input, however, renaming the Local State or Preferences files did nothing. Renaming the Local State just gave me my usual startpage plus a Welcome to Opera page. Renaming the Preferences wound up corrupting my extensions and deleted all their saved data. I had to copy my backups back into the main Opera folder. I even tried deleting these two files and restarting Opera and had the same issue with corrupt extensions and no flash. โ˜น As I said earlier, I will be sticking to Vivaldi should I have to deal with a flash dependent site. I am not that tech savvy and messing with jargon heavy things makes me nervous. I do appreciate all the help you've offered though. Thanks! ๐Ÿ‘

  • This easy way worked for me.

    Then you can add http://*, https://* and file:///* to options.


    Windows 10 (x64) | Anniversary Update
    Opera Stable ยท Beta ยท Developer

    Opera Test profile | Opera Back up Linux ยท Mac ยท Win

  • opera this flash player problem seem to be on the latest opera version 49. because version 48 works fine. why on earth would the opera staff take away some option from flash player probably the main reason flash player don't work. have you guys ever hear the saying don't fix something that is not broken. fix this problem i really don't want have to move to another browser if i do i wont came back to opera, i hate changes when something is working just fine.

    yes im mad because i lost lots of time on the web because flash player will not work with opera version 49

    ty

  • @maxonnxc said in Opera updated to 49 and now having flash player problems:

    why on earth would the opera staff take away some option from flash player

    Opera didn't do it. Google took the option (and the code that supports it) out of Chromium and since Opera uses Chromium, it automatically inherits the change.

  • @zalex108 said in Opera updated to 49 and now having flash player problems:

    This easy way worked for me.

    I assume the widevine of those steps has nothing to do with the Flash issue though.

    If downgrading and then upgrading again fixes whatever's wrong in @slythergirls's profile, that'd be great. If it does work, I wonder if it has anything to do with the profile or just corrupted program files. For example, maybe just downloading the 49 offline installer and installing over the top of the current 49 will fix things.

  • @slytheringirl said in Opera updated to 49 and now having flash player problems:

    @burnout426 Thanks for all your input, however, renaming the Local State or Preferences files did nothing.

    ๐Ÿ˜ž Was worth a try. Maybe trying what I mentioned in this post might work.

    Another option would be to just delete the "cache" and "media cache" folders in the "AppData\Local\Opera Software\Opera Stable" folder.

    @slytheringirl said in Opera updated to 49 and now having flash player problems:

    As I said earlier, I will be sticking to Vivaldi should I have to deal with a flash dependent site. I am not that tech savvy and messing with jargon heavy things makes me nervous.

    Understood. No problem. If you change your mind on testing more and you find something that works, please share though for others that have the specific issue you have so they can try it. It is possible though that some Vivaldi users might run into the same issue some times as it's based on Chromium just like Opera.

  • @burnout426 said in Opera updated to 49 and now having flash player problems:

    I assume the widevine of those steps has nothing to do with the Flash issue though.

    It made the difference for Spotify to work.
    It was asking for Flash until pasted the WiDevine content folder.

    At least was the fix in my case for 2 profiles.

  • @burnout426 if you are going to give out editing help give more detail where theses files are located.. not everyone knows where to look...

  • @burnout426 so google did this to us messed up flash player. then im going to google forums do so bitching there.. i apologize to opera for my previous reply.
    also opera version 48 does work with flash player, but how do i disable operas auto update? im quiting opera everytime i install opera version 48 it auto updates to version 49 and this does not help me out one bit im trying to get away from version 49. im just tired of waiting for a fix for version 49 so im leaving opera going back to firefox.

  • I had the same problem and could not solve it on the old profile.
    The problem for me was the Preferences file, which like the rest of the profile was old.
    I mean that the profile was made in czasch when Opera does not yet have the bookmarks bar.
    If you want me to describe how I did it, write back to me.
    I warn you that for this you need to have an account for synchronization.

    One more thing. I do not know English. I'm writing by translator.

  • @maxonnxc said in Opera updated to 49 and now having flash player problems:

    but how do i disable operas auto update?

    In the program files folder ("C:\Program Files\Opera" is the default on 64-bit systems) there are 1 or 2 version folders. In the one with the highest version, rename opera_autoupdate.exe.

  • @maxonnxc said in Opera updated to 49 and now having flash player problems:

    @burnout426 if you are going to give out editing help give more detail where theses files are located.. not everyone knows where to look...

    Here are the profile and cache folder locations for Opera Stable:

    Profile:
    "C:\Users\yourusername\AppData\Roaming\Opera Software\Opera Stable"

    Cache:
    "C:\Users\yourusername\AppData\Local\Opera Software\Opera Stable"

    Those and the install folder are listed under "Paths" in "Menu -> About Opera" (which is opera://about). To see the AppData folder and its files and folders, you might have to click "View" and check "hidden" in Windows Explorer.

    "Preferences", "Local State" and other such files are in the Profile folder (as in, the roaming "Opera Stable" folder).

    To disable auto update, rename "%installfolder%\%latestversion%\opera_autoupdate.exe".

    The profile folder location is listed in the FAQ pinned thread also.

  • @maxonnxc To disable the auto update, first delete or rename the opera_autoupdate.exe file then use Task Scheduler to disable it. Hit Windows Key+R then type taskschd.msc (You may need Admin permission for this. If you do then search for Task Scheduler using Windows search and right click on it then select "Run as Admin"). Once you have Task Scheduler running, scroll down under the Task Scheduler Library folder for "Opera Scheduled AutoUpdate" then delete it.

  • @slytheringirl said in Opera updated to 49 and now having flash player problems:

    @maxonnxc To disable the auto update, first delete or rename the opera_autoupdate.exe file then use Task Scheduler to disable it. Hit Windows Key+R then type taskschd.msc (You may need Admin permission for this. If you do then search for Task Scheduler using Windows search and right click on it then select "Run as Admin"). Once you have Task Scheduler running, scroll down under the Task Scheduler Library folder for "Opera Scheduled AutoUpdate" then delete it.

    Renaming opera_autoupdate.exe is enough.

    Scheduler would be easily managed using cCleaner or SystemExplorer.

    At the other hand,
    Opera gives a new name to the Schedule task in each update - I wonder why -, so it has to be done each time if you always block the autoupdate.

  • I have tried unsuccessfully yo fix the issue I have with just ONE site, the page keeps asking me to install flash and I do then, it just keeps doing the same thing????
    I guess I will have to use another browser until Opera fixes this issue. ๐Ÿ˜ž

  • @pendaws What site? Have you tried going to opera://site-engagement and then changing the base number for the site to 100? I find that usually works for me for my current session. Sometimes you may have to refresh the site after doing this or maybe even close the tab then return the site but the site-engagement method does work.

Log in to reply