Opera Mail sending good mail to "Junk"

  • I was in the Opera > Mail > Labels > Rules tab and clicked on something, (I don't remember what), and Opera crashed. Now it automatically sends some good mail to the "Junk" mailbox.

    When it crashed, I was trying to set up an Opera Mail rule for spam, but didn't get done before Opera crashed. However, apparently something got set up. I do not see any rules, for anything, when I go back to that Rules tab now. How can I clear this bogus rule?

    Opera 12.16, Windows XP, IMAP

  • Check the path for the mail folder on Help > About Opera (Mail). Then go to that folder, find the subfolder autofilter and delete filter_8.ini.

    You may also want to uncheck the "learn from labelled messages" option for the spam/junk view.

  • IMAP

    If your IMAP server supports as Spam/Junk IMAP folder and learns from messages that you move in and out of it, you don't need to use Opera's spam filter at all. On the "IMAP" tab in the account's properties, disable the spam filter for the account and make sure to set your IMAP spam folder. That way, marking/unmarking messages as spam will move messages in and out of the IMAP spam folder so the server learns.

    Even if you disable the spam filter for the account, I like to right-click on "All Messages/Spam", goto "properties" and turn off the internal filter and turn off "learn from labeled messages" (as locg suggested) just in case.

    The reason to disable the spam filter for the IMAP account is that it can cause major problems and wipe out your messages if the server has its own spam handling.

    You may also want to uncheck the "learn from labelled messages" option for the spam/junk view.

    You can uncheck that option for any of your Opera labels too. Also, unchecking it should dlear the autofilter ini file. But, I never trust it and like to close down Opera and delete the file myself.

    Note: For the learning option, Opera uses a very simple method of learning. When you add a message to the label/spam filter, it'll then look at all the words in the message as spam hints where if any one of the words shows up in a future message, that message will be considered spam too. The idea then is that you have to unmark false positive messages as spam (or unlabel them in the case of labels) to consider all the words in them to not be spam. You then go back and forth until Opera learns. Takes a long while.

  • Opera crashes
    Well, I think I know what I did that made Opera crash. If I click Opera, hover over Mail, click Labels, click Match messages in: All Messages, hover over All Messages, this dropdown list appears:
    All Messages
    Unread
    Received
    Pinned
    Outbox
    Sent
    Drafts
    Spam
    Trash

    If I right click on any of the items in that list, Opera crashes. I don't think that's supposed to happen :) Isn't that where you're telling me to
    "You may also want to uncheck the "learn from labelled messages" option for the spam/junk view" (leocg), and
    "Even if you disable the spam filter for the account, I like to right-click on "All Messages/Spam", goto "properties" and turn off the internal filter and turn off "learn from labeled messages" (as locg suggested) just in case", (burnout)?

  • Yep, Opera should not be crashing. Try renaming the mail folder and add your account again to test. If there are no crashes then there may be something corrupted on your old mail folder.

  • If I right click on any of the items in that list,

    Right-clicking those items in the Match Messages In drop-down shouldn't crash Opera. But, there's no reason to right-click them as there's no context menu for them. Does left-clicking them (to select one of them) cause Opera to crash too? If so, I remember there being a known crasher with Match Messages In where changing it to "Received" or "Inbox" for a POP account would crash Opera. I don't remember the exact steps to reproduce, but I don't think it was ever fixed. I did try to reproduce the problem myself and couldn't with my mail profiles. So, it may indeed be something messed up with your mail folder.

    Isn't that where you're telling me to
    "You may also want to uncheck the "learn from labelled messages" option

    "Learn from labeled" messages is on the "options" tab in the properties for a label (or All Messages/Spam). The "Internal Filter" settings is on the "Rules" tab in the properties for "All Messages/Spam". You don't have to mess with "Match messages in" to change those settings.

  • leocg, thanks for another help. I renamed my \Local Settings\Application Data\Opera\Opera\mail to mailOld, and built my two e-mail accounts again. (One is IMAP and one is POP3.) The sequence I gave in my last comment crashes Opera when I do it on the new IMAP account, too.

    Does it make any difference that I have other IMAP folders, (INBOXes), besides the eight under "All Messages"? Like, I have INBOX.Deaf, INBOX.E-commerce, INBOX.eBay, etc, and am "Subscribed" to them.

    (By-the-way, are there instructions anywhere on Opera telling how to use html when writing these comments?)

  • The sequence I gave in my last comment crashes Opera when I do it on the new IMAP account, too.

    What about the poo3 one?

  • "Learn from labeled" messages is on the "options" tab in the properties for a label (or All Messages/Spam). The "Internal Filter" settings is on the "Rules" tab in the properties for "All Messages/Spam". You don't have to mess with "Match messages in" to change those settings.

    Oh.

  • FIXED

    The problem is fixed. I haven't had mail mysteriously disappear since May, when I made the changes listed under "WHAT I'VE DONE", below.

    WHAT I DIDN'T REALIZE

    I didn't realize that Opera has built-in spam filtering software that is independent of, and separate from, the spam filtering software my webhost provides on my mail server. I had already setup my webhost's spam software. Then, when I setup Opera's software, good mail started disappearing into my Spam folder.

    WHAT I'VE DONE

    I turned off Opera's built-in spam filter. All Messages > right click the Spam mailbox > Properties... > Rules > Internal filter > Off. Then, Options > unchecked "Learn from labeled messages".

    (For the benefit of those reading this who want to learn, Opera's spam software is built into the Opera browser. You activate it in the Properties of the Spam mailbox that appears under All Messages. All Messages is in your Mail panel. If you don't see the Mail panel when you're reading your mail, hit F4. If you still don't see your Mail panel, hit Shift F12 > Panels > checkmark Mail. That'll bring up the Mail panel. Then, if you don't see a Spam mailbox in the Mail panel, click the wrench to the right of the Compose heading, and checkmark All Messages. Now, right click the Spam mailbox, and click Properties.... In the Spam dialog box, on the Rules tab, change Internal filter to Medium or Strong. Then, go to the Options tab, and checkmark "Learn from labeled messages". -- Or, if like me you want to turn it off, change Internal filter to Off.)

    I also disabled local spam filtering in this specific e-mail account. Opera > Mail and Chat Accounts... > double clicked [my IMAP account] > IMAP tab > checked "Disable local spam filter for this account (server-side filtering)".

    THANKS
    I thank you guys, (and gals), for your help!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.