Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I have been using Opera since version 8.0 in windows. For many versions this problem plagued Opera. It does not close, keeps running and you can't start it until you kill all instances using task manager.
    I can't believe that this obviously bad code still lingers in Opera, now in Linux.
    Could not find anyone else posting about this, can't be just me.
    I am on Manjaro Linux 17.02 with Plasma KDE.

  • After examining the problem little more it looks like that Opera does close, but you cannot restart it again. While watching running tasks I observed that when Opera starts it starts few processes. Now if I kill one process, and it has to be the right guess, Opera will open.

    I have connected this behavior with how Opera starts. If I set it to "Continue where I left off" this is when Opera fails to restart. If I choose to start with Set of pages, Opera will start every time but it forgets window size and position.

    In both cases pages I chose to open at start are the same.
    Any fix for this? Is it a known bug?

  • Looks like I have solved the problem by installing opera-ffmpeg-codecs. Opera now starts every time.
    I was reluctant to install this package from AUR because of 500MB download that ends up in a 3MB package. How ridiculous is that?!!

    So I am now happy returnee to Opera! Best browser ever!

  • Opera forgetting its size and position is a known and unsolved bug and happends on all distros. I can not help you more with the startup problem as I always use about:blank as start page.

    As the size of opera-ffmpeg-codecs, 500MB is the source of the entire chromium package that is required to build the *-ffmpeg-codecs for the browser you need, either this browser is chromium, opera, vivaldi or any other chromium based browser. Plus, as noted at the comments, to avoid that hussle, the package's maintainer hosts an arch-compatible repo at

  • "Plus, as noted at the comments, to avoid that hussle, the package's maintainer hosts an arch-compatible repo at"

    Thanks. I added that repo but package could not be found.
    Anyways my startup problem is gone, whatever was causing it. it appears that installing opera-ffmpeg-codecs fixed it.