[Solved]Operamail doesn't connect to Yahoo IMAP from last week

  • I have some e-mail address with Yahoo (personal, work...) and until the last week I used them without any problem with Operamail (and Opera 12.17) but in the last days (about 1-2 weeks) doesn't connect to Yahoo IMAP and I receive an error "Authenticate Invalid credentials".
    Obviously the credentials are the same, nothing has changed, and I can access my accounts using the browser with the same credentials.

    Waiting for a solution as soon as possible.
    Thanks, Igor

  • Try changing authentication method.

  • Done, nothing changed.

    AUTH CRAM-MD5: Aurhenticate mechanism not supported.

    AUTH LOGIN: (the usual method) AUTHENTICATE Invalid credentials.

    AUTH PLAIN: AUTHENTICATE Invalid credentials.

    And the other two options: LOGIN Invalid credentials.

  • Maybe Yahoo has changed something? Tty typing username and password again.

    Also did you enable 2nd factor authentication or something similar?

  • I don't know if Yahoo has changed something (they refuse Opera??? In this case Opera team have to investigate with Yahoo team).
    I have retyped user and password, i have also created a new account to try... Nothing has changed.

    I have not enabled 2nd factor or similar, I never access my account in the browser, I use only the client for the mail.

    I noticed that trying to download mails Operamail gives me an error for not known certificate by my AVG antivirus. If i accept it, the program go on and gives me the errors i wrote, if i don't accept it the program ask me again. I have also disabled AVG and so no certificate are asked to be accepted but the errors is always the same.

    But you have a yahoo account that you read with Operamail without problems now?

  • I don't know if Yahoo has changed something (they refuse Opera??? In this case Opera team have to investigate with Yahoo team).

    Since Opera Mail stopped being developed about four years ago, I don't think it will happen.

    I noticed that trying to download mails Operamail gives me an error for not known certificate by my AVG antivirus. If i accept it, the program go on and gives me the errors i wrote, if i don't accept it the program ask me again. I have also disabled AVG and so no certificate are asked to be accepted but the errors is always the same

    Did you check if the account info is correctly informed? Did you try retyping the username and password?

    But you have a yahoo account that you read with Operamail without problems now?

    I don't use Opera Mail.

  • I have retyped and checked all without any solution.

    But if you don't use it how you can help?!?!?!

  • I have retyped and checked all without any solution.

    OK.

    You can try creating a log file to see if it shows something that may help you find the cause of the issue.

    You can create one by editing accounts.ini and adding a path to a text file in the line Incoming Log File= in the section for your Yahoo account.

    But if you don't use it how you can help?!?!?!

    I don't use it since a while but I used it for 10, 15 years so I still remember something about it.

  • i think is a problem with yahoo, because not all my e-mail from yahoo are forward, and i tried to resend verification mail and did not work, so i don't think is from opera mail

  • Download Thunderbird and set up the account in it and see if it works. If so, try using the same settings it uses. As in, after things are set up and working in Thunderbird, goto "Menu -> options -> account settings -> the section for the account in question -> server settings".

    Also, go back to mail.yahoo.com and click on the gear icon at the top right. Then, goto "Account Info -> Account Security". Make sure 2-step verification is *still* off. Also, make sure "Allow apps that use less secure sign in" is enabled. If it is, try disabling it and then re-enabling it. Maybe make sure "Secure your account with Yahoo Account Key." is not set up.

    Try all of that without your Anti-virus email scanner enabled first.

    Under "Account Info", try going to "Recent Activity" to see all what's connected. If there's something funky connected, disconnect it or revoke access.

    Try changing your yahoo password just to see if mail access starts working.

    Make sure time, date, time zone and daylight savings time settings are all correct. In Internet Options in the control panel under connections -> LAN settings, make sure your system isn't using a proxy (unless you know it should be).

    Download the Opera Mail (or Opera 12.17 installer), launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "Standalone Installation (USB)" and install. In that Opera, set up the IMAP account fresh (do not import anything) and see if it works there. Maybe something got messed up with the wand data and or certs in your normal Opera. If things work in this Opera, that's something you should investigate.

    If things don't work in the standalone installation of Opera either, maybe try the standalone installation on friend's computer or something just to see if it works there.

    Maybe Yahoo has some new mail servers with different addresses. I'd search the net/yahoo website to see and try those.

    You can try creating a log file

    Yes. It'd be interesting to see what it says. Maybe it says something more than invalid credentials.

    i think is a problem with yahoo

    Definitely sounds like it at least.

  • Hi,

    Same problem with another client (Kmail) on Linux (I'm also using 12.17 regularly on Linux, and Opera Mail on Windows btw, and I'm regularly discovering new functions). Just solved it. I'll check it on Windows and Opera Mail one of these days.

    1. Activate 2-step verification
    2. Set up 3rd party app password for your client using "Other client"
    3. Maybe delete and re-synchronize your account using the new password
    4. ???
    5. Profit

    It worked fine for me without 2-step verification until a few weeks ago. Enabling it did the trick.
    However the auth method also got changed from "Plain" to "clear text" in the Kmail settings by the automatic detection, dunno if it played a role.

  • I tried all suggestions (by myself before asking here) but nothing is working.

    I have done the log but if I post it the system tells me a moderator have to approve it.

  • You can try creating a log file to see if it shows something that may help you find the cause of the issue.

    This is the log:

    ==== Logging started ====
    07/08-2017 22:19:58 IMAP#1/1: Connecting...

    07/08-2017 22:20:01 IMAP#1/1 IN {}: * OK [CAPABILITY IMAP4rev1 ID MOVE NAMESPACE X-ID-ACLID UIDPLUS LITERAL+ XYMHIGHESTMODSEQ AUTH=plain SASL-IR AUTH=PLAIN AUTH=LOGIN AUTH=XYMLOGIN AUTH=XYMPKI AUTH=XYMCOOKIEB64 AUTH=XOAUTH2 AUTH=OAUTHBEARER] IMAP4rev1 Hello

    07/08-2017 22:20:01 IMAP#1/1 OUT {}: 0000 ID ("name" "Opera Mail" "version" "1.0" "vendor" "Opera Software ASA" "os" "Win32")

    07/08-2017 22:20:01 IMAP#1/1 IN {}: * ID ("remote-host" "2.40.184.37" "vendor" "Yahoo! Inc." "support-url" "http://help.yahoo.com/" "name" "Y!IMAP" "host" "sky700102.imap.mail.yahoo.com" "version" "1.1.10284")

    07/08-2017 22:20:01 IMAP#1/1 IN {}: 0000 OK ID completed

    07/08-2017 22:20:01 IMAP#1/1 OUT {}: [command contains password]

    07/08-2017 22:20:01 IMAP#1/1 IN {}: +

    07/08-2017 22:20:01 IMAP#1/1 OUT {}: [command contains password]

    07/08-2017 22:20:01 IMAP#1/1 IN {}: + eyJzdGF0dXMiOiJpbnZhbGlkX2NyZWRlbnRpYWxzIiwic2NoZW1lIjoiYmFzaWMiLCJzY29wZSI6Imh0dHBzOi8vbWFpbC55YWhvby5jb20vIn0=

    07/08-2017 22:20:01 IMAP#1/1 OUT {}: [command contains password]

    07/08-2017 22:20:01 IMAP#1/1 IN {}: 0001 BAD [AUTHENTICATIONFAILED] AUTHENTICATE Invalid credentials

    07/08-2017 22:20:01 IMAP#1/1: Disconnected: Received disconnect order

    07/08-2017 22:20:05 IMAP#1/1: Connecting...

    07/08-2017 22:20:05 IMAP#1/1 IN {}: * OK [CAPABILITY IMAP4rev1 ID MOVE NAMESPACE X-ID-ACLID UIDPLUS LITERAL+ XYMHIGHESTMODSEQ AUTH=plain SASL-IR AUTH=PLAIN AUTH=LOGIN AUTH=XYMLOGIN AUTH=XYMPKI AUTH=XYMCOOKIEB64 AUTH=XOAUTH2 AUTH=OAUTHBEARER] IMAP4rev1 Hello

    07/08-2017 22:20:05 IMAP#1/1 OUT {}: 0002 ID ("name" "Opera Mail" "version" "1.0" "vendor" "Opera Software ASA" "os" "Win32")

    07/08-2017 22:20:05 IMAP#1/1 IN {}: * ID ("remote-host" "2.40.184.37" "vendor" "Yahoo! Inc." "support-url" "http://help.yahoo.com/" "name" "Y!IMAP" "host" "sky700125.imap.mail.yahoo.com" "version" "1.1.10284")

    07/08-2017 22:20:05 IMAP#1/1 IN {}: 0002 OK ID completed

    07/08-2017 22:20:05 IMAP#1/1 OUT {}: [command contains password]

    07/08-2017 22:20:05 IMAP#1/1 IN {}: +

    07/08-2017 22:20:05 IMAP#1/1 OUT {}: [command contains password]

    07/08-2017 22:20:05 IMAP#1/1 IN {}: + eyJzdGF0dXMiOiJpbnZhbGlkX2NyZWRlbnRpYWxzIiwic2NoZW1lIjoiYmFzaWMiLCJzY29wZSI6Imh0dHBzOi8vbWFpbC55YWhvby5jb20vIn0=

    07/08-2017 22:20:05 IMAP#1/1 OUT {}: [command contains password]

    07/08-2017 22:20:06 IMAP#1/1 IN {}: 0003 BAD [AUTHENTICATIONFAILED] AUTHENTICATE Invalid credentials

    07/08-2017 22:20:06 IMAP#1/1: Disconnected: Received disconnect order

  • I tested myself with my yahoo account. At yahoo, 2-step verification is off. no app passwords are generated, and "Allow apps that use less secure sign in" is enabled. When I set up my account in Opera Mail and it tries to connect, I get an invalid credentials error. This is with the default of auth login. I switch to auth plain in the dialog and try again. Then it connects fine.

    This is with imap.mail.yahoo.com, port 993, TLS checked, auth plain and me@yahoo.com as my username. I'm in the U.S. if it matters.

    Same results with 2-step verification enabled and an "other app" password generated. Opera uses the app password no problem once I switch to auth plain.

  • Hi, I have the same issue. Don't use my yahoo account much, but when I checked it my problem is the same. I tried to connect on my android phone as well and it said it couldn't connect, although a recent email appeared in the inbox. But I can't send from it. Two step verification is disabled and use of less secure apps is permitted.

  • Not very long ago, Yahoo activated OAuth authorization protocol for eMail access, both directly with itself and with its contracted third-party ISP providers (eg: Frontier). OAuth requires a user to obtain a special password from the eMail account provider which places a token on the user device that allows regular log-in to occur. Without it having been set up in the eMail browser, log-in will fail. This may be the 2-step authorization described for Opera, though its compatibility with Yahoo's OAuth may be uncertain, particularly if the user hasn't obtained the special 16-character password from the eMail service provider. I now use Thunderbird myself, having had my former PocoMail eMail program obsoleted when Yahoo went to OAuth (since PocoMail is no longer being updated and lacks OAuth capability).

  • I switch to auth plain in the dialog and try again. Then it connects fine.

    Thanks, now it's working for me too using "Auth plain".
    When the problem started I had tryed all the autenticantion modes without any solution. Probably the Yahoo team have solved the issue.

    Thanks to all for support. 🙂

  • Hi, I have the same issue. Don't use my yahoo account much, but when I checked it my problem is the same. I tried to connect on my android phone as well and it said it couldn't connect, although a recent email appeared in the inbox. But I can't send from it. Two step verification is disabled and use of less secure apps is permitted.

    Here we were discussing the Operamail desktop, in your Android phone you have to use the official and updated Yahoo app.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.