Opera 12.02 initially fails to connect to server but will later--security prefs not enabled?? help

  • Hi everyone!

    I'm still using good ol' Opera 12.02, but lately (even on win7) some websites it won't load initially.
    I get this error message (even though the website loads fine on Firefox)

    Unable to complete secure transaction
    Show Details
    Secure connection: fatal error (40)
    https://time.gov/
    Failed to connect to server. The reason may be that the encryption methods supported by the server are not enabled in the security preferences.
    Please note that some encryption methods are no longer supported, and that access will not be possible until the website has been upgraded to use strong encryption.

    All I have to do, though, is wait.....and wait....if I try again later (without clearing cache, without closing or restarting Opera, without doing anything) the website loads fine.
    Another example would be timeanddate.com. Sometimes it loads fine on the first try, other times it gives me that same error message, and I have to wait and try again later (even though it loads fine right then and there on Firefox)

    I have tried playing with the security settings (different security protocols) but it makes no difference.

    Does anyone have any suggestions? Thanks for your help!!

    SN

  • Why 12.02? There was a security update roughly a year ago (version 12.18) which updated the security protocols in Presto and so should fix this issue.

    You can find it on the FTP archive ... I wasn't sure whether you'd want the English or International version, the only difference is the number of languages included.

    Mind you, 12.18 is still considered outdated by many websites, but it will have fewer of these security errors.

  • sgunhouse, Thanks for your help!

    I tried installing 12.18 (with that handy link you provided), but I get an error right away (after extracting)

    Opera.exe - Unable to Locate DLL
    The dynamic link library UxTheme.dll could not be found in the specified path
    (then next box says:
    Failed to load Opera.DLL because the specified module could not be found)

    I knew there had to be a reason why I stopped at 12.02 on my windows 2000 machine (with Pentium 3's)

    Or is there some setting I need to tweak in windows to get this installer working?

    Even so, I would still like to know something else: How can I still connect on 12.02 to those websites that give me that problem? Is there a way to tweak my Opera security settings for those particular websites so that they will load?

    Thank you to anyone else for any suggestions here!!

    SN

  • The UxTheme.dll library is a digitally-signed (in modern Win versions) file unique to each Windows version and that is associated with running themes under Windows, including its own themes. If it is truly corrupted, missing, or its digital signature can't be verified each time it's run, it will usually cough up an error message upon system reboot or changing between user accounts. In that case, forcing a 'system restore' either via safe mode or using the command line if even accessing safe mode causes such an error (enter in the command line: rstrui.exe), will usually restore the file. Corruption can occur for a number of reasons, not the least of which is running special themes or theme patchers on the system.

    On the other hand, if the system is successfully booting without a UxTheme error message but an application installation is failing with that error message, either the file is only partially corrupted or something is blocking the Opera installer from properly accessing the library file. Sometimes, restoring the UxTheme.dll file by running the System File Checker (SFC), restoring the file from an OS backup, or running 'system restore' will clear such apps installation problems.

  • Thanks! It looks like version 12.18 is only meant for win7k (they excluded win2k) So it looks like I'm out of luck to get 12.18 running on win2k

    So I'd like to ask:
    Is there a way to tweak my Opera 12.02 security settings for those particular websites (that have more recent security settings) so that they will still load on my older browser?

    I'm hoping somebody has an idea here for me to try! Thanks for any help!!

    SN

  • The changes were not all in settings - some new protocols were added. While you can enable settings that were not enabled originally, you can't add new ones.

  • sgunhouse (or anybody else who can offer help here),
    Is there a way to set my security preferences "low" so that it will still load a website using security protocols not understood by the 12.02 version?

    I'm just wondering if there is a workaround to getting websites to load still on Opera 12.02 without having to upgrade.

    Thanks!
    SN

  • @skewnerd said in Opera 12.02 initially fails to connect to server but will later--security prefs not enabled?? help:

    ...
    I'm just wondering if there is a workaround to getting websites to load still on Opera 12.02 without having to upgrade.
    ...

    It depends on the website server. When you go to an https site, there is a negotiation back and forth between that site's server and your system to determine just what connection protocol and related encryption choice will be used for the visit. If the site indicates a required range of protocols and sets of encryption choices none of which are available with the browser, the connection will fail and you'll get a failure notification. The website sets the rules on what kind of connection choices it requires to be used, and the browser simply tells the server what's available on the browser in the user's system. Some websites will allow the negotiation to descend even to include old or deprecated encryption schemes, but that's not considered good security practice - particularly if significant personally-identifying data is involved at any point in accessing or using the site. As time goes by, fewer and fewer sites will allow the old deprecated connection schemes, and the ones that do should always be treated very carefully in terms of what personal or account data you expose while connected. There are good reasons old connection protocols and encryption schemes get deprecated - and they all involve insecurity issues.

    One of the key problems with old OS's and their browsers is that they become truly obsolete in certain areas with the passage of time. A result is more and more limitation in what they can do (or safely do) online in a technologically evolving online universe. In a similar way, more and more limitations come to exist in what software versions are compatible with the aging OS. You're running into both these issues.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.