VPN Getting "An error occurred" on page that works fine in all other browsers

  • Hi,

    This page of our site, which works great on all other browsers:
    http://www.alphachooser.com/car_gps-the-latest-gps_with_backup_camera_input
    ... returns this error msg while browsing with the VPN on:

    "An error occurred.
    Sorry, the page you are looking for is currently unavailable.
    Please try again later.
    If you are the system administrator of this resource then you should check the error log for details.
    Faithfully yours, nginx."

    Yet, the same page works fine on many other browsers, such as chrome, firefox, Vivaldi, etc.

    My questions:
    Q: Is this something WE should change?
    Q: Any other website experiences the same problem (upon searching this forum, I was surprised to not see any other msg about that error msg)?
    Q: Why would some pages of our site (see below) work but not others (see below)?
    Q: Can it be fixed please?

    Note that:

    • The same problem happens on my Android smartphone when using the VPN host application, very same error message (even on other browsers, in this case, as long as the VPN app is on), so it really seems to be VPN-related.
    • Some other pages of the same site, like our home page, work fine even on the VPN, but other pages display the same behavior (VPN only), for example these:
      http://www.alphachooser.com/car_gps-the-latest-motorcycle_gps
      http://www.alphachooser.com/car_gps
      and many others.
  • What your server admins say? For me it seems that the server is blocking the VPN.

  • Thanks,

    After verification, it seems like our server is not (or does not seem to be) blocking the VPN, as one of the tests i conducted showed that the server received the opera for developper request and sent the data with a 200 code, see log extract here:

    107.182.233.175 - - [07/Jun/2017:19:33:30 -0500] "GET /microwave_ovens-the-latest-best_over-range_microwave_ovens HTTP/1.1" 200 13544 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.26 Safari/537.36 OPR/46.0.2602.0 (Edition developer)"

    Yet, the page failed with the usual error msg (mentioned at the beginning of this thread).

    In further tests, I took the actual HTML of the very same page and saved it under a different file name and uploaded it to:
    http://www.alphachooser.com/test-mwpage-asis.htm

    Again, that's the very very same page, but then it works, even on VPN!

    It seems to indicate that:

    • it is not the HTML itself that makes it crash, right?
    • it does not seem to be my server either, as the error msg comes from nginx, and I'm serving from apache.

    And raises the following questions:

    • could it be the filename? Yet it looks pretty ordinary: http://www.alphachooser.com/microwave_ovens-the-latest-best_over-range_microwave_ovens
    • how is it that the very same page served dynamically from a PHP script fails, yet the very same HTML (obtained from the very same PHP script) succeeds? Is the Opera VPN able to see that it is coming from PHP and doesn't like that? Yet there are millions of PHP websites...
    • Is NGINX involved in that VPN? And if NGINX is what handles that VPN, then the msg seems to be from the VPN itself, but then again what does it dislike exactly?
    • Finally, could it be the headers? I got the headers of the PHP vs HTML versions from webconf's check header service and they look like this:

    PHP (standard) version:

    HTTP/1.1 200 OK =>
    Date => Thu, 08 Jun 2017 00:53:58 GMT
    Server => Apache/2.2.31 (Unix)
    X-Powered-By => PHP/5.3.3
    Cache-Control => max-age=14400
    Content-language => en
    Set-Cookie => lint-item=Bosch+HMV8052U%3A%3Amicrowave_ovens%2F%2F%2FSharp+R-1214%3A%3Amicrowave_ovens%2F%2F%2FGE+PVM9215%3A%3Amicrowave_ovens%2F%2F%2FFrigidaire+FGMV175QF%3A%3Amicrowave_ovens%2F%2F%2FSamsung+ME21F707%3A%3Amicrowave_ovens%2F%2F%2FLG+LMV1683ST%3A%3Amicrowave_ovens%2F%2F%2FFrigidaire+FFMV164LS%3A%3Amicrowave_ovens%2F%2F%2FAmana+AMV1150VAS%3A%3Amicrowave_ovens%2F%2F%2FFrigidaire+MWV150KW%3A%3Amicrowave_ovens
    X-Content-Type-Options => nosniff
    Expires => Thu, 08 Jun 2017 04:53:58 GMT
    Vary => Accept-Encoding
    Content-Language => en
    Connection => close
    Content-Type => text/html; charset=UTF-8

    STatic HTML test version:
    HTTP/1.1 200 OK =>
    Date => Thu, 08 Jun 2017 00:55:40 GMT
    Server => Apache/2.2.31 (Unix)
    X-Content-Type-Options => nosniff
    Last-Modified => Thu, 08 Jun 2017 00:40:22 GMT
    Accept-Ranges => bytes
    Content-Length => 103206
    Cache-Control => max-age=14400
    Expires => Thu, 08 Jun 2017 04:55:40 GMT
    Vary => Accept-Encoding
    Content-Language => en
    Connection => close
    Content-Type => text/html; charset=UTF-8

    Could it be some of the differences seen here? I'd really appreciate some help, as this is kinda mind boggling.

  • Hello.

    Our company also encounters such problem.

    All browsers can successfully display company web-site (bfshina.com.ua), but after Opera VPN enabled - it display error with Nginx (we are using Apache) http://bfshina.com.ua/operavpn_fails_on_access.png. Web-server log shows, that query was successfully accepted and data send back to client agent: http://bfshina.com.ua/other_sites_access_log_with_opera_vpn_IP_connect_tries.png.

    Thanks for help.

  • It looks like we are now 2 with the same problem, but still no official reaction. Is there a way we can get an official answer on that?

  • I can see the problem happening on the mentioned pages here.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.