[Solved]YouTube Dark Mode Bug?

  • Hi Everyone,

    After the latest update to v45, I've been having issues with YouTube's dark mode. I'm not sure if this is an issue with the browser or not, but it seems to have only happened since the update so I figure worth asking about anyway. When I access YouTube, it seems to default to YouTube's normal (light) mode, even though the toggle may be set to Dark Mode On. If I change the toggle, it will switch to the other mode regardless of what the toggle label says. I feel like this is very confusing to try to explain, so here are some images:

    This is what YouTube should look like in it's Normal (Light) Mode, and you can see the toggle is off:

    This is what YouTube should look like in Dark Mode, and we can see that the toggle is on:

    Once I have turned Dark Mode on, if I close and re-open the tab, YouTube reverts back to light mode, even though it shows Dark Mode is still on:

    If I toggle YouTube's Dark mode OFF, it switches over to Dark Mode:

    I tried clearing browsing history, cookies, etc. but still no luck. My apologies if this isn't a browser issue, but as I mentioned it coincided with the update so I'm making assumptions. Thanks for your time.

    Version: 45.0.2552.635 (PGO) - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit

  • Exact same issue and I doubt a reinstall would fix this site specific problem =|
    Quite annoying.
    It does make you wonder though what went on behind the scenes between Opera 44 and now to create this bug.

  • I couldn't find an option to enable dark mode on YouTube.

  • I couldn't find an option to enable dark mode on YouTube.

    Not off topic? x)

    Click on your avatar in the top-right corner and then click Dark Theme. If you don't see it, it's because you're still on the old YouTube. Go to youtube.com/new to use the new YouTube. You can change back to old YouTube by clicking the avatar in the top-right and clicking Restore classic YouTube.

  • Not off topic? x)

    Nope. I'm trying to check the issue subject of this topic.

    Click on your avatar in the top-right corner and then click Dark Theme

    No such option here.

    If you don't see it, it's because you're still on the old YouTube. Go to youtube.com/new to use the new YouTube

    Well, if it's still an experiment then issues are expected. I see the same happening on Firefox and Vivaldi.

  • My apologies if this isn't a browser issue, but as I mentioned it coincided with the update so I'm making assumptions.

    Did you check on other browsers? Here I see the same happening on Firefox and Vivaldi.

  • leocg, thanks you so much for taking your time to look into solutions.

    I hadn't made the effort to try other browsers, as it mysteriously coincided with me updating opera. It had been working fine, and then as soon as I restarted opera after the update, it stopped.

    I just downloaded Chrome and tried that, as you pointed out it has the same issue, so it appears it isn't specific to the Opera update.

    My apologies for the rookie error in my troubleshooting, sorry for the hassle!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.