[Solved]Troubles with Stylish, increase dramatically Opera CPU consumption

  • Hi,

    I had troubles with Opera CPU consumption, it was way too high, like ~40% or ~50%. And I tried to see what was causing that, and finally it looks like Stylish is responsible.

    I haven't been able to create a new profile because I can't find a Profile folder in the path that has been given nor a Profile, but I've cleaned the cache and the cookies.

    So, in my case :

    The more pages you open the more the consumption increase ... I don't understand. I've been using Stylish and this script for a long time now, and this high consumption problem just appeared.

    Version : 43.0.2442.1144 (PGO) - Une erreur s'est produite lors de la vérification des mises à jour
    Flux de mise à jour : Stable
    Système : Windows 10 64-bit (WoW64)

    Btw, "Une erreur s'est produite lors de la vérification des mises à jour" means "An error occurred while checking for updates"

    So maybe my browser is updated ?

    Thanks

  • First of all, did you report the issue to Stylish author(s)?

    I haven't been able to create a new profile because I can't find a Profile folder in the path that has been given nor a Profile

    The given path is the profile folder.

    So maybe my browser is updated ?

    Lastest stable version is 44.0.2510.1218

  • I sent a PM to him, but I tried to see if I had the problem with another Style and actually the CPU usage increase with another Style ...

    Oh so I have to delete everything that is in that folder (Opera Stable) ?

    Yea that is the version I have now ! :)

  • Oh so I have to delete everything that is in that folder (Opera Stable) ?

    Not necessarily, you can just rename the folder. This way you can return to the old profile if the new one doesn't solve the issue.

  • Oh yea, that definetely changed something. I'm at 10% of CPU Usage with 6 tabs opened, I installed the same script, with Stylish, and everything is OK now ...

    Thanks a lot leocg ! I think that it solved the problem. I'll keep you updated if the problem come back with the other addons ! :)

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.