Opera does not open links in new tab

  • Due to my work I often deal with links containing UTM tags. May the presense of UTMs in the address of the link affect the problem?

  • @avl I've also found one interesting peculiarity: when this problem happens to a page (I Command - click on a link and the page in the hew tab is blank), in case I right-click on this same link and select "Open in new tab" in the context menu, the page in new tab loads OK. So I do not think it has to do with memory at all. It's just some bug. Technically nothing interferes with opening a new Tab, but it just does not work properly

  • We've found the cause of this issue and hopefully we can release a fix soon. When you have this problem, try doing this as a workaround:

    • Enable the Developer menu if you haven't yet (View -> Show Developer Menu)
    • Click Developer -> Task Manager
    • Select "GPU process" and click "End Process"

    This should bring back the blank tabs.

  • @avl Thank you so much! I hope this issue to be fixed, that would be awesome. Thank you for the workaround suggestion, will ry to use it next time I experience this problem.

  • @avl under ,About this Mac' I see ...

    MacBook Pro (15-inch, Late 2011)
    2.2 Ghz Intel Core i7
    4 GB 1333 MHz DDR3
    AMD Radeon HD 6700M 512 MB
    Intel HD Graphics 3000 384 MB

    Thanks for help! 🙂

  • @avl The workaround hint you provided works OK, thank you! Really helps. How will we know when the fix is released? (even with the hint the issue is really annoying)

  • @laoshe the next stable update of Opera will include the fix. If you're really curious, http://www.opera.com/blogs/desktop/ has full changelogs for every release and will have a post when the next version is released.

  • @avl Thank you! will be waiting for the update

  • I'm having the same problem (sent email weeks ago). Mac is MBP (2009) 2.8ghz core 2 duo 8MB
    tabs open under existing tab and URL of existing tab stays the same but the page displays content from the original page - not the tab-opened page. clearing cache works for a day or so.

  • ain´t sure if my problem is the same.. facebook pages when open in background tabs are very slow to load up, in the same tab they open normal

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.