[Solved]Black screen when opening links from Facebook

  • I have encountered a weird new bug/error in Opera after the newest update (I think). Happens when opening links from Facebook with a middle-mouse button (and only from Facebook as far as I've tried).

    I have a habit of opening links in Facebook posts in the background tabs. Recently, however, whenever I open a tab with a middle-mouse-button click, when I go to that new tab, it's black. The Opera UI is present, all okay, but the page itself is black. (The mouse cursor changes according to the possible links and text in the black page - as if the page itself loaded but some bug places a black screen upon it). As I have mentioned above, only happens with links (and JUST the written links, not thumbnail links) from Facebook and ONLY with the middle-mouse button click. Although, whenever I open through right-mouse button option "Open link in new tab", all is fine.

    I suppose it's some sort of bug with Facebook links and middle-mouse button.

    Version: 44.0.2510.857 (PGO) - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit
    I have ticked "Delay loading of background apps" in the settings.

  • I remember have read other reports about it but I never faced it myself.

  • ievaday

    Try disabling hardware acceleration and restarting Opera

  • I found 2 more people who had a similar problem after upgrading to Opera 44.0.2510.857 (PGO) and they also had Windows 10 x64; Opera 44.0.2510.857 (PGO) x64
    I advised them to turn off the hardware acceleration, after which they all began to work fine.
    It turns out that this update broke something in hardware acceleration on Windows 10 x64

  • I'm having the same problem! It happens when I middle-click links on Facebook & gmail so far as I've noticed.

    I'm using Opera version 44.0.2510.857 (PGO) on Win 10 64-bit

    @temkem: I tried disabling hardware acceleration, didn't work.

  • @temkem

    Thank you, temkem, disabling HA worked for me.
    Any ideas what triggers this? It used to work fine.

    @yavannagreen

    I'm thinking - perhaps update your video drivers?
    Or if you have a laptop with two graphics cards - an integrated one and a more powerful one - set Opera to use the integrated one.
    Wild guesses, though.

  • I have the same problem. Black screen when opening links from Facebook. ( WIN 10 )

  • On the site https://vk.com in the Russian-speaking group Opera
    Many people write about the problem of black and sometimes white screen on Windows 10 after the Opera update to version 44.0.2510.857 (PGO). Helps to disable hardware acceleration. Developers already know about this problem or need to send a bug report?

    https://vk.com/wall-23292255_26439?reply=27285

    https://vk.com/wall-23292255_26439?reply=27287

    https://vk.com/wall-23292255_26349?reply=27225

    https://vk.com/wall-23292255_26439?reply=27273

    https://vk.com/wall-23292255_26439?reply=27185

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.