Opera Mail: Disabling Notification

  • I'm new to Opera, so bear with me, please. I just installed the Opera Mail client and so far it's okay. I am having one problem I can't seem to overcome.

    In settings there is an option to disable "Show notification for new messages". I uncheck the box and exit, but notifications still display. I go back in and the box is checked. Is there a way to disable these notifications? They are showing up constantly. It's set to check mail every 5 minutes, but these message notifications are popping up one after the other, non-stop. Any advice?

  • How many mail accounts do you have, and what type (POP3 or IMAP)? Also - obvious question - did you click Okay when you changed the setting? (If you clicked Cancel or the "X" in the corner of the dialog then you didn't save the changes.)

  • I have 5 POP3 accounts, no IMAP. I did click Okay. :)

  • What you're noticing is a known problem with the checkbox being broken. To work around it, you have to close down Opera and edit operaprefs.ini in the "preferences" folder. See "Help -> About -> Opera Mail" for the location. Under "[User Prefs]", you have to set (add it if it's not there):

    Show Notification For New Messages=0
    

    There's also:

    Show Notification For No New Messages=0
    

    if you want to turn off the "No new messages" notification when checking for new mail.

    Save the settings to the file and start Opera. Then, never mess with the checkbox again or it'll mess things up and you'll have to edit the file again.

    Note though that Opera Mail was discontinued years ago. So, this issue and others will never be fixed.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.