Unable to find update / auto-update : opera for mac 37.0

  • Thanks in advance for all help...

    Im attempting to both update my mac 37.0 opera browser,
    and initiate an update. Ive found no solution for either.

    Ive checked the opera about page - there's no update link there
    Ive checked everywhere in preferences.

    The information here is not applicable to my version:
    http://help.opera.com/Mac/11.60/en/autoupdate.html

    I dont want to wipe out the browser but perhaps ill have to...
    Spent 30 min or more searching forums, and could not find an answer.

    -Vega

  • What version of OSX?

    As stated in the blog post announcing Opera 38, Opera 38 (and all versions since, of course) requires OSX 10.9 or later. I've noticed a bunch of posts lately about OSX 10.7.5; unfortunately such an old version will not be compatible with more recent versions of Opera.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.