VPN not connecting

  • I installed Opera yesterday and VPN worked.

    Today VPN just says Connecting...

  • Welcome to Opera Forums @Operabobbob!

    Actually there are many posts issuing VPN problems but we didn't identify the problem yet.
    In your case, has been made any change:

    • In Opera - Extensions, flags?
    • In the network?
    • In the computer?

    Try with a new profile explained in the Frequently Asked Questions (Opera for Windows)
    and or disable Antivirus too.

  • Opera seemed to be working fine for me until it asked me to restart to upgrade the browser to version 43.0.2442.991 (PGO)
    Now I have the same problem described by Operabobbob.. It might be a complete coincidence it happened at the same time as the update.. but either way, it's painful.

    I just got Opera a week or so ago, and was fairly happy with it - great options to save me battery life and system resources (kills Chrome and others in that respect)... Have had a some issues as it does not support some websites (and vice versa - like my banking site)... I could look past these little things as it worked for the most part, and integrated VPN was a key reason I got it (which worked great), and now not working already :(

    Not sure if it's normal when "connecting" (because every time before now it connected really quickly), but I only have one location option now too

    PLEASE HELP, OPERA!

  • Welcome to Opera forums @Aldorei9n!

    Have you tested the suggestions for Operabobbob?

    If none of them works, then just rename / delete the latest update in ProgramFiles/Opera and test with the older version.
    As Opera will detect an older version it will try to update itself again, just:

  • Thanks for your response, @zalex108!

    Okay, so I went through the couple of different options. I will explain my experience, and how I eventually got it running:

    • First, I tried changing the folder name for the current profile folder, and this allowed the VPN to work again, but I lost all other customisation, etc. (obviously). When this happened, in the hope I would not have to manually change everything to the way I had it, I deleted the new profile folder created by Opera and reverted back to the original folder. After this the VPN again would not work again.

    • Next I tried to roll-back the update, as you gave the instruction for, but afterwards Opera would not open at all (even if I tried to launch directly from the application icon in the program files, rather than the shortcut).. I reverted back to the latest version folder..

    • Finally (and how I got it working with my profile in tact), I went back to the profile folder, renamed it, and opened Opera. It created a new profile folder as before. I then close Opera. Next, I went to the location of the profile folders, deleted the contents of the newly created folder and copied the contents of my original profile folder (that I had renamed) into the folder created by Opera (also, deleting the folder I had renamed afterwards). I opened Opera again, and hey presto! everything was back and the VPN worked again :love:

    Thanks for your help @zalex108!! You saved the day! :cheers:
    I hope that my experience can help you @operabobbob, and any others with the same issue.. If any of my explanation is unclear, please ask and I can clarify .

  • [] Next I tried to roll-back the update, as you gave the instruction for, but afterwards Opera would not open at all (even if I tried to launch directly from the application icon in the program files, rather than the shortcut) []

    I forgot to mention:
    The file "installation_status.xml" has the version number, so for use the Launcher.exe it needs to be changed (reverted) to the old Opera too.

    :rolleyes:

    [] Finally (and how I got it working with my profile in tact), I went back to the profile folder, renamed it, and opened Opera. It created a new profile folder as before. I then close Opera. Next, I went to the location of the profile folders, deleted the contents of the newly created folder and copied the contents of my original profile folder (that I had renamed) into the folder created by Opera (also, deleting the folder I had renamed afterwards). I opened Opera again, and hey presto! everything was back and the VPN worked again []

    :up: Very good young Padawan StarWars
    :lol:

    [] I hope that my experience can help you @operabobbob, and any others with the same issue []

    :up:

    [] Thanks for your help @zalex108!! You saved the day! []

    :lol:
    Nice to hear that :up:

  • UPDATE

    I restarted my computer last night and the VPN went down again. Seemed like the same problem as last time, as it wouldn't work for the remainder of the night. However, back up today..

    @zalex108 (or anyone else), is there somewhere to check the VPN service status?

    Thanks in advanced!

  • , is there somewhere to check the VPN service status?

    Nope.

  • Nope.

    Stiff.. :confused:

  • X/

    Do you have any VPN extension?
    You may repeat the steps to create a new profile and then add just the most important data, some extensions may wait to be installed to check if there is a problem with them.

  • I have had the same issue of VPN just connecting. I use Avast Antivirus [free] and disabled it for 10 minutes and I was able to use VPN, change number and restart Avast. Hope this helps someone.

  • @amadhatter Thanks for that suggestion it worked. I turned off AVG for a minute, restarted Opera, turn AVG back on and everything was back to normal. I hope I don't have to go thru that every time I restart.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.