Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I have my cookie settings set to remove cookies upon exit, with various google exceptions:,, I log in to google, and see my settings in search, gmail, etc. But after closing the browser, I'm logged out. This only happens with Google. I can log into Bing, close the browser, and b/c there is a bing exception in my cookie list, I stay logged in.

    What can I do about the google cookies/logins?

    Using O Next if that matters.

  • I don't have Opera set to remove cookies on exit - but it won't stay logged in on this site or another forum, both of which use the HTTPS protocol. I've decided it is precisely because both sites do use HTTPS that Opera is doing this. I don't particularly use Google services, but I am reasonably sure Gmail would use HTTPS ...

  • Hmm you might be on to something. However, after being logged into Bing, I tried logging OUT (to see how they have me log in) and Opera wouldn't let me log out. After clicking the "sign out" option on, my browser took me back to bing and I was still signed in. Logging in with IE at gave me no problems, so I'm thinking that Opera still has some cookie issues, or problems with sites that have https logins. I don't know. Being able to log in and out, and stay logged in when cookies are enabled, are things that I take for granted in a browser.

  • As sgunhouse has pointed out, it is important that you use the right protocol: when it's https, you must set https in the cookie exceptions. Most probably, you're still lacking some domain names on the exception list. Enable all cookies temporarily to re-check which domains provide cookies when logging in to Google.

  • Enabling all cookies did the trick. I realized that Google inserted a; placing that in my exceptions has allowed me to stay logged in. Interesting.

  • Spoke too soon.

    I'm still not staying logged in to my Gmail. I have put https:// in front of all my google domains in the exceptions, and still it won't work. Tried clearing out all cookies and cache, logged in, closed browser, and I'm logged out.

    This is irritating.

  • I checked in the Google forum and evidently it has been an issue with Chrome users as well. Here is what one member wrote. Not sure if it will help since I'm not home on my Opera browser.

    "I resolved this by un-installing Chrome. Then I restarted it and navigated to the hidden data app folder:


    I deleted the Google folder and emptied the bin.

    I then reinstalled Chrome and it finally kept my signed in.

    Windows 8 Pro x64

  • Finally found what I needed to do. In the cookie manager in the Settings, they have a "Manage Exceptions" button. When you click on that, you see an example---something like [.] I did this for google, and now the cookies are being saved and I'm staying logged in across browser sessions. Normally just the ordinary website is enough . Most of my cookie excptions are things like But if that won't work, follow the instructions and use [.] in front of it. Now it is working fine. I deleted all of my google entries except for [*.] and it is working fine.