Opening Word/Excel etc documents automatically

  • Just started with Opera and it's find except that it doesn't open Word and Excel documents automatically - it puts them in the downloads folder. In 'Opera Help' it says "You can decide how Opera should handle files you download by going to Settings > Preferences > Advanced > Downloads". But there is no 'Preferences' option! Whatever reasons Opera may give for not opening these documents automatically, this is what I have been doing for many years and this is what I want to continue doing. Also, I find that it seems impossible to contact Opera directly about problems - there is only this forum to use, in the hope that someone might come up with a good solution to your problem. It is such bad practice not to allow direct communication with the provider/operator etc. They really don't want you to be able to do this - but it causes so much frustration.

  • Like many others before you, you've actually been looking at help files that only apply to the old Presto-based Opera, not to the new versions.
    Opera really should have sorted their help pages out by now to make it clear which versions they apply to!
    IIRC the current versions of Opera cannot open any files directly, they can only save the files so they can be opened later.
    🙂

  • I have the reversed problem for PDF files.

    the current versions of Opera cannot open any files directly, they can only save the files so they can be opened later.

    Not true (anymore), yesterday Opera started to open PDF files without even prompting for download!
    My current settings is Always ask where to save files and Open PDF files with the standard program for PDF files, but then I clicked on a pdf link today the download started without asking, downloaded the file and opened it automatically.

    How can I disable automatic downloading and opening?

    Someone on the german sub-forum found this change aswell: http://forums.opera.com/topic/19193/pdf-mal-wieder

  • Not true (anymore), yesterday Opera started to open PDF files without even prompting for download!

    Check your plugins. Find "Chromium PDF Viewer" or any similar PDF viewer plugin and disable it.

  • Chromium PDF viewer was disabled before, something probably changed in an update. I changed a new setting telling Opera to not use the built in PDF viewer but instead use my default one. It uses my default now, but it still downloads and opens without asking!

    As written in the linked topic in my last post, the poster cant find the plugins menu anymore and it is the same for me. Maybe I should ad that my version of Opera is 43.0.2442.806

  • Is it no longer there under Settings>Websites>Plug-ins>Manage individual plug-ins?
    If not, try just putting opera://plugins/ into the address bar.
    🙂

  • As written in the linked topic in my last post, the poster cant find the plugins menu anymore

    Menu > Developer > Plugins

    t uses my default now, but it still downloads and opens without asking!

    I guess it's the expected behavior when you say to open PDFs in the default reader in settings.

  • As written in the linked topic in my last post, the poster cant find the plugins menu anymore

    Menu > Developer > Plugins

    I'd forgotten it's there as well!
    It's possible that the people who asked about it don't have the developer menu visible though, I don't think it is by default IIRC.
    🙂

  • It's possible that the people who asked about it don't have the developer menu visible though, I don't think it is by default IIRC

    I guess you need to enable it on Menu > More Tools.

  • Thank you, I found the plugins.

    The expected behavior is that Opera asks if I want to save the file and where ("save as") and not start downloading directly. I also expect Opera to not open downloaded files automatically. I looked under plugins and Chromium PDF viewer was still disabled but the first PDF files I downloaded after the update opened in Opera, before I found the setting to open in my default program. Not sure how that works...

    So I decided to test a few things. Apparently I can not enable Chromium PDF viewer ("Disabled by company policy" ??, this is my home computer). This looks like it means that it is overridden by the "Open in default"-setting. Changing the setting changes the state in plugins. Testing the different combinations does effect how PDFs are opened but no combination opens the save as window!

  • When you disable PDF Viewer plug-in, you enable the setting 'Open PDF files in the default viewer application'.

    That's why the expected behavior is that PDF files should be opened directly. To download them you need to right click on the link and use 'save linked content as'.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.