Can't get to hidden Opera Preferences page

  • I am reading a tutorial on how to set up Opera with a socks proxy, and it told me to put in opera:config into the address bar. It's supposed to bring me to a Opera Preferences page kind of like Firefox's about:config page. It only brings me to the regular "Settings" page. I have also tried opera:config#UserPrefs, and I still get to the normal Settings page. Has Opera taken away this feature? Is there some file I can edit instead? I really need to access these settings. The tutorial that I'm trying to follow is this one: http://jponiato.hubpages.com/hub/How-to-Use-Opera-with-a-SOCKS-Proxy#

  • Someone said that the opera:config page was changed to opera://flags

    I tried that, and I can't find any proxy settings in this page. Please help! I want to set up a socks5 proxy in Opera, just like I did in Firefox!

  • This tutorial is for Opera Presto (Opera 12 and older), the new Opera Blink (Opera 15+) doesn't have those settings yet.

  • Someone said that the opera:config page was changed to opera://flags
    I tried that, and I can't find any proxy settings in this page. Please help! I want to set up a socks5 proxy in Opera, just like I did in Firefox!

    Menu > Settings > Network.

    Opera Blink uses the OS proxy settings.

  • Uggghhh, oh well. I gave up. I downloaded an old version (version 11.10) from here: http://www.oldversion.com/windows/opera/

    Then I followed the directions from the previous link I provided. I guess Opera got rid of socks proxy support? Oh well. At least I have the old version and it works fine for what I need.

  • Goto "internet options" in the control panel. On the "connections" tab, click "LAN settings", check "user a proxy" and click "advanced". There you can enter the socks info.

    I think it might only be socks4 and not 4a or 5 though. I would think it'd work fine with Chrome/New Opera though since it uses the system proxy settings. However, enabling it for the system sucks if you only want to enable it for just Opera.

    As leocg said, you can get to the connection settings for the system by going to "Menu -> settings -> Network" and clicking "change proxy settings".

    http://sockslist.net/articles/google-chrome-proxy-how-to-use is a visual of what you have to do.

  • Hi,
    the Windows 'Internet Options' don't allow for authentication with SOCKS5 which may have been the original point of the post. This is what brought me here. I've gone back to a version 12 which still has the option for username and password for SOCKS5.
    Paul

  • I've just learned that SOCKS5 with authentication is still available in another less popular browser which names begins with 'Max...'

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.