Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

Hello, in order to introduce new security features and enhance your experience with Opera Forums we have to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button in the upper-right corner of the page.
This is a one-time action. Sorry for any inconvenience!

[Solved]Opera 42 stop "Save as" prompt at download.

  • I just reinstalled Win 10 pro and a new copy of Opera (42.0.2393.94). Now every download is interrupted with a Save As prompt using windows file explorer. Mostly it has the download directory correct -- but not always, and if I'm not attentive my download can wind up in some other place, like Documents. This happened in recent versions but only for exe files, and then it stopped. How can I stop this behavior? Something in Flags?

  • Is 'Ask where to save each file before downloading' disabled?

    To disable the download prompt when downloading executable files you can disable opera://flags/#prompt-on-risky-download but always remember that a flag can go away at any time.

  • Thanks for the info. But. . . It was already set to "default" (disabled). I changed it explicitly to disabled and restarted Opera. No change, still does it. Oh well.

  • Ok. Didn't take the first, second and third times. Fourth was good. Thanks again.

  • It was already set to "default" (disabled).

    You mean the flag? At least here the default is 'enabled'.

  • You are probably right. I may have misread it. Anyway, all is good.

Log in to reply