Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Clicking a link in an email causes Opera to only open a new empty tab (i.e. speed dial)

  • I installed a fresh copy of Ubuntu 16.04 on an HP 280 (Intel Core i3-4170 cpu, 3.8 gigs ram, 64-bit), copied over my home directory from backup which included the ~/.config/opera/ directory, installed Thunderbird and Opera (among other programs), and now clicking links in emails causes Opera to only open a new empty tab (i.e. the speed dial).

    I did a sudo apt purge opera-stable, moved .config/opera to .config/opera.old, installed Opera 42.0.2393.85 via a freshly downloaded .deb file, and still the links opened only an empty tab.

    I changed my default browser to Firefox, and clicking the links in an email work.

    I then changed the default browser back to Opera, and they open an empty tab again.

    How can I make Opera work again?

  • I just discovered that this problem also occurs when opening a link from the terminal, so it must be an Opera problem.

  • Sort of ... it is most likely an issue with the startup script.

  • Which startup script?

  • I googled "opera startup script" but didn't find anything. @sgunhouse, I assume you're talking about an Opera startup script, as I can't see what my Ubuntu startup script would have to do with how Opera accepts a clicked link and opens it. Can you (or anyone else) tell me more about this startup script or have any other advice as to how I might fix my problem?

  • The file found when you type "opera" on a command prompt is a script, it sets a few system variables before calling the actual opera binary. Every once in a while they make a mistake in the script and forget to pass the command line to the binary.

    I run the Developer version and thus can't tell you what the stable version has in its script at this point. The Developer version works properly when I click a link in my email, so I'll assume it's an error in the script as described - unless it's a setting in your email software as to what program is called and how. But as you said it also happens from a terminal, I guess we can exclude the email program.

  • I see. Thanks for the info. I did a "find . -iname opera" on /usr, and came up with: "/usr/share/bash-completion/completions/opera". Is this the script you're talking about?

    If the problem is in this script, though, wouldn't this be a widespread problem? I'd think something like that would have been reported and fixed already. Regardless, it'd be good to investigate this angle, so I'm wondering if you could post your script or suggest any changes to mine?

    My Opera bash-completion script:

    # opera(1) completion                                      -*- shell-script -*-
        local cur prev words cword
        _init_completion || return
        case "$prev" in
                _filedir -d
                COMPREPLY=( $( compgen -W 'openURL\\( openFile\\( openM2\\(
                    openComposer\\( addBookmark\\( raise\\(\\) lower\\(\\)' \
                    -- "$cur" ) )
                [[ $COMPREPLY == *\( ]] && compopt -o nospace
                COMPREPLY=( $( compgen -W 'first last opera{1..9}' -- "$cur" ) )
                # argument required but no completions available
        if [[ "$cur" == -* ]]; then
            COMPREPLY=( $( compgen -W '$( _parse_help "$1" -help )' -- "$cur" ) )
            [[ $COMPREPLY == *= ]] && compopt -o nospace
        _filedir '@(?([xX]|[sS])[hH][tT][mM]?([lL]))'
    } && complete -F _opera opera
    # ex: ts=4 sw=4 et filetype=sh
  • openM2? Looks like something from Opera 12 ...

  • That would be very strange as I haven't used Opera 12 on this computer. Could it be that when I copied over my ~/.config/opera/ directory something from Opera 12 came over from way back when I did??? And then this something caused a change in /usr/share/bash-completion/completions/opera that persisted even after I purged and reinstalled Opera from scratch???

  • I deleted /usr/share/bash-completion/completions/opera completely now, and Opera behaves the same: links clicked in an email and the terminal still just bring up an empty (i.e. speed dial) tab.

    Any help?

  • Upgraded to Opera 42.0.2393.94, and it's still happening. Why? This is so weird. What can be done to fix it?

  • What email are we talking about here? Presumably T-bird ...

  • Yes, Thunderbird, but it also happens when opening a link from the terminal. This is why it seems like definitely an Opera problem.

  • I finally found a solution to this issue here. It was option 2 in Ronald P's answer.

    Basically, somehow my ~/.local/share/applications/opera.desktop file got messed up:

    [Desktop Entry]
    Name=(72) Facebook - Opera

    Adding %U to the end of the Exec= line fixed it. (And, of course, I got rid of "(72) Facebook - " in the Name= line. How the heck did this happen??? Dunno, but this is how to fix it in case anyone else has this problem. Man, I tolerated this problem for MONTHS! Glad it's finally fixed.