What OSs are actually supported?

  • The only download I can find for Linux is a Debian package, which CentOS refuses. Is there a support matrix I can refer to and/or install rpms for an OS other than Debian?

    Kind regards,
    Humbug

  • Thanks for this, however I get the following errors reported:-
    warning: opera-stable_41.0.2353.46_amd64.rpm: Header V4 RSA/SHA512 Signature, key ID f6d61d45: NOKEY error: Failed dependencies: libnotify.so.4()(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64 libstdc++.so.6(CXXABI_1.3.5)(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64 libstdc++.so.6(GLIBCXX_3.4.14)(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64 libstdc++.so.6(GLIBCXX_3.4.15)(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64

    :doh:

    I've explored with yum and got the response that the latest versions of both libnotify and libstdc++ were already installed.

    For clarity, the output from uname -a is:-
    Linux bah.humbug 2.6.32-642.4.2.el6.x86_64 #1 SMP Tue Aug 23 19:58:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

    I tried installing libnotify-devel and I've even tried soft-linking the required names to the module availale in /usr/lib64 with no change in the messages.

    Any further clues? :confused:

    Kind regards,
    Humbug

  • Ooh, that didn't post well. O.O Let's try again.

    Thanks for this, however I get the following errors reported:-

    warning: opera-stable_41.0.2353.46_amd64.rpm: Header V4 RSA/SHA512 Signature, key ID f6d61d45: NOKEY
    error: Failed dependencies:
        libnotify.so.4()(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64
        libstdc++.so.6(CXXABI_1.3.5)(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64
        libstdc++.so.6(GLIBCXX_3.4.14)(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64
        libstdc++.so.6(GLIBCXX_3.4.15)(64bit) is needed by opera-stable-41.0.2353.46-0.x86_64
    

    :doh:

    I've explored with yum and got the response that the latest versions of both libnotify and libstdc++ were already installed to the latest version.

    For clarity

    # uname -a
    Linux bah.humbug 2.6.32-642.4.2.el6.x86_64 #1 SMP Tue Aug 23 19:58:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
    

    I tried installing libnotify-devel and I've even tried soft-linking the required names to the module available in /usr/lib64 with no change in the messages.

    Any further clues? :confused:

    Kind regards,
    Humbug

  • I'm guessing your distro's versions of those libraries are just too old for Opera's tastes. You're still running a 2.6 kernel after all... :)

    CentOS aims for system stability and that requires sacrificing the ability to run bleeding-edge software. Unfortunately all modern browsers fall in that category.

    I don't think Opera has a LTS version. It might be possible to grab and install an older version with older depencies from the FTP site.

  • Another try using yum to try to resolve the dependancies got me this similar output:-

    # yum localinstall opera-stable_41.0.2353.46_amd64.rpm
    Loaded plugins: fastestmirror, refresh-packagekit, security
    Setting up Local Package Process
    Examining opera-stable_41.0.2353.46_amd64.rpm: opera-stable-41.0.2353.46-0.x86_64
    Marking opera-stable_41.0.2353.46_amd64.rpm to be installed
    Loading mirror speeds from cached hostfile
     * base: mirror.0.net
     * extras: mirror.1.net
     * updates: mirror.1.net
    mycompany                                                                                                                                                                                | 2.9 kB     00:00     
    Resolving Dependencies
    --> Running transaction check
    ---> Package opera-stable.x86_64 0:41.0.2353.46-0 will be installed
    --> Processing Dependency: libstdc++.so.6(CXXABI_1.3.5)(64bit) for package: opera-stable-41.0.2353.46-0.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: opera-stable-41.0.2353.46-0.x86_64
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: opera-stable-41.0.2353.46-0.x86_64
    --> Processing Dependency: libnotify.so.4()(64bit) for package: opera-stable-41.0.2353.46-0.x86_64
    --> Finished Dependency Resolution
    Error: Package: opera-stable-41.0.2353.46-0.x86_64 (/opera-stable_41.0.2353.46_amd64)
               Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
    Error: Package: opera-stable-41.0.2353.46-0.x86_64 (/opera-stable_41.0.2353.46_amd64)
               Requires: libstdc++.so.6(CXXABI_1.3.5)(64bit)
    Error: Package: opera-stable-41.0.2353.46-0.x86_64 (/opera-stable_41.0.2353.46_amd64)
               Requires: libnotify.so.4()(64bit)
    Error: Package: opera-stable-41.0.2353.46-0.x86_64 (/opera-stable_41.0.2353.46_amd64)
               Requires: libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    

    Sorry, but I'm still stuck. Naturally trying to --skip-broken would be foolish and the Opera rpm would still refuse to install anyway.

    Kind regards,

    Humbug :XP:

  • Many thanks red-wizard. Postings crossed. Sadly I can't get to the FTP site. I guess we've blocked it off. :doh:

    What I need is some sort of browser VPN tool to bypass the company firewall, something like um, well, Opera perhaps ...... :rolleyes:

    Kind regards,

    Humbug :faint:

  • They may instead have blocked the FTP protocol - http://ftp.opera.com/pub/ may work.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.