Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Plug-ins

    "Detect and run important plug-in content (recommended)" is clicked, I have no exceptions.

    If I go to nbcnew video page,

    http://www.nbcnews.com/video

    ...none of the videos that I click play, if I right click in any of those video images (which all have the play button in the middle) it treats it as if it were just an image, not normally like if Opera sees it as a video, the right click will display what player is being used, if it is Flash it will note that have have a "Settings" displayed. The nbcnews site has nothing at all like that, it is just a photo image that I can "Save Image"

    I have struggled with this for a number of iterations here, and it's clear it's something in MY Opera (or my laptop) that is causing this, because my other laptop (both HPs) DOES play the videos, noting it is pdk platform...a Flash video

    (I appreciate your help, Leo)

  • Leo, I have gone through ALL of my Opera 40 settings on the problem Opera laptop and the one that DOES play nbcnews.com videos, and they are exactly the same. I have disabled ALL extensions, disabled Opera's ad blocking.

    I am totally perplexed.

  • You could try a clean Opera profile to see if it helps.

  • Heh! No way am I going to "start over" for the sake of nbcnews.com

    🙂

  • Heh! No way am I going to "start over" for the sake of nbcnews.com

    It would be just to check if the problem is on the profile.

  • Ok, so what do I do, delete the contents of the entire Opera Software folder in Roaming after copying it to somewhere safe??

    Then try out Opera without a profile, if the video plays we can take it from there bit by bit, and if the video still doesn't play, I just copy the contents of the folder back...and I will have everything as before??

  • leo, how about I DL the beta version and try that....if I do that can I uninstall that version and my Opera 40 will remain?

    Ok, I Dled the beta, and yes the videos DO play...what should I do?? I could simply keep beta and use it, but I'll bet when it goes stable and it gets installed over current Opera, the problem will continue.

    Help

  • Sounds to me like you have a problem in your profile. Different installs of Opera use different profiles. You likely have a problem in the profile of Opera Stable. Just rename your existing profile and Opera will make a new one. If the problem goes away you know your old profile in damaged and you should just transfer over things like your passwords and bookmarks to the new profile.

  • Ok, will try that, how about my Speed Dial, and Extensions?? Can I move them folder by folder?? And when/if I move a folder over and the problem pops up again, I will know it's in that folder...right??

  • Ok, what I did was renamed the Opera Stable folder, and then booted Opera (which created a new Opera Stable folder default folders and files). Now the video plays...and one by one I replaced files from the original folder into the newly created Opera Stable folder.

    What I came up with was when I replaced the new "Preferences" file with the older, larger version that was in the the original Opera Stable folder, the video does not run. So I've now isolated the problem.

    If I delete the "Preferences" file, a LOT of my stuff is gone as Opera creates a new default one, so I don't want to do that...all my Speed Dial entries, etc. are missing and other stuff

    Now I've got to figure out what it is in that Preferences file that is messing with the videos. The file has a LOT of stuff in it (opened with notepad) and I have no idea as to how to isolate the line(s) that are creating the problem...Help??

  • Honestly it would be easier to delete the file and reset your preferences manually then it would be to try and edit out whatever it is that is causing the problem.

  • When you say reset your preferences manually, where is it that I set my preferences? Are we talking about Opera flags or some other place that I set preferences?

    Because in that file there is a very high number of references to individual websites etc. I don't have a clue where those particular preferences came from.

  • I've tried deleting my preferences and letting Opera write a new one. However I end up losing ALL my extensions, and my settings are a little screwed up.

    if there is anyone out there who can school me regarding editing my Opera "preferences" file, please step forward...there is something in there that disallows me from playing videos on http://www.nbcnews.com/ as well as http://www.espn.com/

    Thanks

  • Don't just delete your preferences file. You have to create a new profile and then import things over to it.

  • Lando, what do you mean "create a new profile" - how do I do that, sorry for being so "dumb" I'm learing as I go. Appreciate your help

  • What you did in this post:

    Ok, what I did was renamed the Opera Stable folder, and then booted Opera (which created a new Opera Stable folder default folders and files).

    is creating a new profile folder. It is correct.

    What I came up with was when I replaced the new "Preferences" file with the older, larger version that was in the original Opera Stable folder, the video does not run. So I've now isolated the problem.

    And there is where you screwed up. The preferences file is damaged. It is the source of your problems. DO NOT USE IT. Use the preference file created from the new profile.

  • Using the NEW preferences file solves one problem (allowing me to play videos on nbcnews and espn) but creates a whole new issue, having to re-install all myextensions, of which I have MANY. it seems to me there MIGHT be a way for me to get Opera to "see" those extensions by overwriting the now empty (or missing) extension folders. It seems that the presence of those extension is depending on something in my preferences. Is that right or can I do something with the old extension folders (I have everything in the renamed Opera Stable folder).

    Plus ALL of my Speed Dials are gone. (Many)

    Addendum, I found my Speed Dials from the old folder, now I have them put in correctly. All I need now is to find a way for Opera to find my extensions, and I would be good to go, I have ALL my bookmarks, bookmark bar is set up, just the extensions, without having to find them, install them individually, and configure each of them like I had before.

    What a mess.

  • ALL of my Speed Dials are gone.

    Have you checked 'Bookmarks Manager > Other Speed Dials'?

  • Leo, I DID find the Speed Dials, but I had to move a few folders over from the previous folder, now I need to get the extensions.

  • it seems to me there MIGHT be a way for me to get Opera to "see" those extensions by overwriting the now empty (or missing) extension folders.

    Go to the extensions manager, turn on 'Developer mode' and click on 'Load unpacked extension'.

    In the dialogue window, look for the extension folder in the old profile and select the (sub)folder with the version number. Click 'OK'.

    It should 'import' the extension into the new profile.