Video WiIl Not Play Opera 39

  • http://www.nbcnews.com/news/us-news/keith-scott-shooting-no-definitive-evidence-he-pointed-gun-cops-n652631

    Windows 7.

    Plays fine in IE; also plays fine in Opera for Android.

    The image shows the play arrow, but when clicked, nothing at all happens. All of nbcnews.com's videos behave the same as this one. I've posted about this before, however no one has come up with a solution.

  • I have another laptop, with the same setup: Windows 7 and Opera 39...and the video DOES play there. On that laptop I have no extensions...so I disabled ALL my extensions on the one that I have the problem with, disabled ad blocking.

    Still the troubled Opera does not play any nbcnews videos.

    I now have Opera 40.0.2308.62, and the same problem exists there also.

    Help.

  • i had trouble with Flash Player not starting in Opera 36 using Flash Player 23 ppapi , so deleted flash player from the registry and opera 36 and used firefox to download Flash Player 22 and opera 28 it works now but with my uninstall program its still says i'm using flash player 23 ppapi and Opera 36 and using Operas menu and about opera it says opera 36 wtf ! but its working now , its so damn strange

  • This problem has existed on my laptop before Flash 23, so it's not the version of Flash that is the problem, IMO

    Other web sites that have Flash work fine using F23

    Thanks for your comment.

  • The image shows the play arrow, but when clicked, nothing at all happens

    What are your settings for plug-ins?

  • Adobe Flash Player
    Version: 23.0.0.162
    Shockwave Flash 23.0 r0

    Location:
    C:\Windows\SysWOW64\Macromed\Flash\pepflashplayer32_23_0_0_162.dll

    Type:
    PPAPI (out-of-process)

    application/x-shockwave-flash
    Shockwave Flash
    .swf
    application/futuresplash
    FutureSplash Player
    .spl

  • No, I mean in settings > websites > plugins.

  • Plug-ins

    "Detect and run important plug-in content (recommended)" is clicked, I have no exceptions.

    If I go to nbcnew video page,

    http://www.nbcnews.com/video

    ...none of the videos that I click play, if I right click in any of those video images (which all have the play button in the middle) it treats it as if it were just an image, not normally like if Opera sees it as a video, the right click will display what player is being used, if it is Flash it will note that have have a "Settings" displayed. The nbcnews site has nothing at all like that, it is just a photo image that I can "Save Image"

    I have struggled with this for a number of iterations here, and it's clear it's something in MY Opera (or my laptop) that is causing this, because my other laptop (both HPs) DOES play the videos, noting it is pdk platform...a Flash video

    (I appreciate your help, Leo)

  • Leo, I have gone through ALL of my Opera 40 settings on the problem Opera laptop and the one that DOES play nbcnews.com videos, and they are exactly the same. I have disabled ALL extensions, disabled Opera's ad blocking.

    I am totally perplexed.

  • You could try a clean Opera profile to see if it helps.

  • Heh! No way am I going to "start over" for the sake of nbcnews.com

    🙂

  • Heh! No way am I going to "start over" for the sake of nbcnews.com

    It would be just to check if the problem is on the profile.

  • Ok, so what do I do, delete the contents of the entire Opera Software folder in Roaming after copying it to somewhere safe??

    Then try out Opera without a profile, if the video plays we can take it from there bit by bit, and if the video still doesn't play, I just copy the contents of the folder back...and I will have everything as before??

  • leo, how about I DL the beta version and try that....if I do that can I uninstall that version and my Opera 40 will remain?

    Ok, I Dled the beta, and yes the videos DO play...what should I do?? I could simply keep beta and use it, but I'll bet when it goes stable and it gets installed over current Opera, the problem will continue.

    Help

  • Sounds to me like you have a problem in your profile. Different installs of Opera use different profiles. You likely have a problem in the profile of Opera Stable. Just rename your existing profile and Opera will make a new one. If the problem goes away you know your old profile in damaged and you should just transfer over things like your passwords and bookmarks to the new profile.

  • Ok, will try that, how about my Speed Dial, and Extensions?? Can I move them folder by folder?? And when/if I move a folder over and the problem pops up again, I will know it's in that folder...right??

  • Ok, what I did was renamed the Opera Stable folder, and then booted Opera (which created a new Opera Stable folder default folders and files). Now the video plays...and one by one I replaced files from the original folder into the newly created Opera Stable folder.

    What I came up with was when I replaced the new "Preferences" file with the older, larger version that was in the the original Opera Stable folder, the video does not run. So I've now isolated the problem.

    If I delete the "Preferences" file, a LOT of my stuff is gone as Opera creates a new default one, so I don't want to do that...all my Speed Dial entries, etc. are missing and other stuff

    Now I've got to figure out what it is in that Preferences file that is messing with the videos. The file has a LOT of stuff in it (opened with notepad) and I have no idea as to how to isolate the line(s) that are creating the problem...Help??

  • Honestly it would be easier to delete the file and reset your preferences manually then it would be to try and edit out whatever it is that is causing the problem.

  • When you say reset your preferences manually, where is it that I set my preferences? Are we talking about Opera flags or some other place that I set preferences?

    Because in that file there is a very high number of references to individual websites etc. I don't have a clue where those particular preferences came from.

  • I've tried deleting my preferences and letting Opera write a new one. However I end up losing ALL my extensions, and my settings are a little screwed up.

    if there is anyone out there who can school me regarding editing my Opera "preferences" file, please step forward...there is something in there that disallows me from playing videos on http://www.nbcnews.com/ as well as http://www.espn.com/

    Thanks

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.