:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Opera won`t start on Kali Linux

  • I cant start opera in Kali, when I click on the icon it just doesnt show up.
    I tried from the command line and got the following error:

    root@KLKali:~# opera
    [0826/105810:FATAL:sandbox_linux.cc(180)] Check failed: sandbox::Credentials::MoveToNewUserNS().
    #0 0x0000039612de <unknown>
    #1 0x000003975a6b <unknown>
    #2 0x00000065b172 <unknown>
    #3 0x000003163cac <unknown>
    #4 0x000002e09236 <unknown>
    #5 0x000002e0a437 <unknown>
    #6 0x000002e08f50 <unknown>
    #7 0x000003d9b1fa OperaMain
    #8 0x7f12a67e3730 __libc_start_main
    #9 0x00000045bf85 <unknown>

    Received signal 6
    #0 0x000003960e67 <unknown>
    #1 0x7f12a7e31ed0 <unknown>
    #2 0x7f12a67f61c8 gsignal
    #3 0x7f12a67f764a abort
    #4 0x000003960352 <unknown>
    #5 0x000003975d2a <unknown>
    #6 0x00000065b172 <unknown>
    #7 0x000003163cac <unknown>
    #8 0x000002e09236 <unknown>
    #9 0x000002e0a437 <unknown>
    #10 0x000002e08f50 <unknown>
    #11 0x000003d9b1fa OperaMain
    #12 0x7f12a67e3730 __libc_start_main
    #13 0x00000045bf85 <unknown>
    r8: 00007fff7ab68300 r9: 00007f129fab9a80 r10: 0000000000000008 r11: 0000000000000202
    r12: 000000009a17b701 r13: 000018139a1daa80 r14: 00007fff7ab68a68 r15: 00007fff7ab68a58
    di: 0000000000000001 si: 0000000000000001 bp: 00007fff7ab690b0 bx: 0000000000000000
    dx: 0000000000000006 ax: 0000000000000000 cx: 00007f12a67f61c8 sp: 00007fff7ab68198
    ip: 00007f12a67f61c8 efl: 0000000000000202 cgf: 6d63000000000033 erf: 0000000000000000
    trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
    [end of stack trace]


    Then I tried to start with no sandbox and opera does start but gives the following errors:

    root@KLKali:~# opera --no-sandbox
    [0826/105426:ERROR:browser_main_loop.cc(227)] Running without the SUID sandbox.
    [0826/105427:ERROR:object_proxy.cc(583)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.InvalidArgs: No such interface 'org.freedesktop.UPower.Device'
    [0826/105429:ERROR:sandbox_linux.cc(343)] InitializeSandbox() called with multiple threads in process gpu-process.

    Even with the errors it works fine but I need to keep the terminal open while using opera.
    I don`t know much about it but my guess is that the energy saving thing is not being able to find Kali energy management system.

    Is there any way to fix that? having the terminal open every single time is somewhat annoying...

  • Is Kali one of those "no DBUS" distros?

  • Dude, take a read on this Markdown and next type post cleanly, please.
    Use the apostrophe as an apostrophe, not the backtick (reserved - it's heavy formatting here).

  • He just pasted what was there, it's a lot of work to reformat that much text ...

  • Right...
    :thinking:

    HTML also works here.
    And it might seem some Markdown doesn't work within (certain) elements...
    Steve, can you fetch the original input for yourself? You could try some in that thread of ours in "Feedback" - that which is for testing.
    Or can one just put two backticks there on both sides? :confused:

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.