Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

CSS and images not rendered

  • Everything works fine on my end. It has to be something specific about your setup that is causing the problem if you are the only one experiencing it. We're just trying to help you track down what it is.

  • We're just trying to help you track down what it is.

    How? Telling me there's something wrong on "my setup"? Can you be more specific? Because I have installed Opera 36 for XP to see how it renders websites that don't work anymore in Opera 12.17. Immediately after a default installation of Opera 36, the website suggested didn't work. What a progress...

    And all this while Firefox works perfect. Thing is I am not a fan of FF, but I might have to become one because Opera fails me.

    It is a matter of SSL for sure (see post above) and by reading other topics I see that Opera team will not address new SSL cyphers.

  • Then, when I set this option back again, to how it had been, the problems did not return.
    Err...?

    Probably because the necessary data was already downloaded?

    Possibly. Anyway, this needs updating.

    It does seem that, for whatever reason, the latest version of Opera (Ver. 39.0.2256.48) does need the option: 'Block third-party cookies and site data' to be disabled. Otherwise I get two problems on one website I use - Firstly, very slow loading of pages. Secondly, some site icons do not display correctly, though they still work. (And they display correctly with the 'Open image in new tab' menu option.)

    AFAIK this was not the case in previous releases of Opera. Why this should be so I do not know. Perhaps something has changed on the site? Perhaps the option did not really work as intended on previous releases of Opera? Perhaps there is a fault with the latest version of Opera?

    But something has changed, there can be little doubt about that. I have previously used Opera with this option set and not encountered problems previously with the sites I use.

  • In fact, why would it have something to do with not loading CSS and images??

    It's not unusual that those softwares block loading of pages or its elements.

    It's Opera's fault. Firefox works.

    Since you seem to be the only one with the problem, i would say that the chances of it be Opera's fault may be very low.

    How Chrome, Vivaldi or other Chromium based browsers behave on that page?

    My guess is Opera fails at SSL protocols.

    As 36 is a old version it really may be missing more up-to-date security protocols.

  • It does seem that, for whatever reason, the latest version of Opera (Ver. 39.0.2256.48) does need the option: 'Block third-party cookies and site data' to be disabled.

    That option is disabled by default.

  • AFAIK this was not the case in previous releases of Opera. Why this should be so I do not know. Perhaps something has changed on the site?

    I would bet on it.

  • How Chrome, Vivaldi or other Chromium based browsers behave on that page?

    I will never install Chrome or any other clone of it. The only exception I did was to try Opera 36.

    As 36 is a old version it really may be missing more up-to-date security protocols.

    Well, it's the latest on XP OS, can't do much about it, can I? Except maybe importing latest SSL certificates. As for "upgrading" my OS, it's a NO too. I don't need overbloated OSs that don't offer me any REAL improvement to my daily work. Only because they're newer or trendy that's not enough to be better. Oh yeah, I can't play 25 GB games... big deal...

  • Well, it's the latest on XP OS, can't do much about it, can I?

    You can update your OS. If you are going to keep using an obsolete OS, you should take responsibility for your decision.

    As for "upgrading" my OS, it's a NO too. I don't need overbloated OSs that don't offer me any REAL improvement to my daily work.

    Well, for me just (lack of) security would be a very strong reason to update.

    And you say you don't need a new OS until you get in the day where you will no longer be able to do lots of things because you will be using old versions of programs that can't deal with changes in technology.

    In fact, you seem to be facing it with Opera.

  • masster, I took some time to analyze your problem.

    With my Opera that page looked fine, so I downloaded Opera 36 portable and it also looked fine, this on Windows 7. So then I tried with Opera 36 portable on my XP VM and there you have it: that site looked just like in your screenshot.

    I googled for that error in the console and indeed it's related to the SSL certificate. For its HTML content, that site uses a certificate provided by StartCom which uses SHA256RSA, and Windows 7 provides it. XP has a smaller list of trusted certification authorities, and only has the one for StartCom that uses SHA1RSA, but it seems if the newer version is not available, the older one can be used. But for the content (css, js, gif, jpg), which come from img11.warez-bb.org, it uses a certificate provided by Comodo, and that's not present in XP. It seems Firefox has its own list of certificate providers, so that's why it works there.

    The Certificates window in XP has an Import button, so there might be a way to import something from Comodo which would let you browse that site without this issue. I wouldn't look for a hack to make Opera disregard unknown certificates, for quite obvious reasons.
    I tried exporting the certificates from Firefox and from Windows 7 and importing them in IE but it didn't work. Maybe you can spend some more time and have more luck.

  • But something has changed, there can be little doubt about that. I have previously used Opera with this option set and not encountered problems previously with the sites I use.

    A further update. This problem seems to have cleared up now on the problem site. There is some suggestion it could have been due to routing/timing problems over the Internet. Other than that I have no idea.

Log in to reply