[Solved]Video has a green overlay

  • So I'm running Opera Beta 40.0.2306.0 on Windows 10. But when I play a video it has a green overlay. Why?

  • Any example?

    Are your video card drivers up to date? What are your video card?

    Does opera://gpu/ show any error message? What about opera://media-internals/ ?

  • I have a screen capture but how do I post it? I have a Radeon 6950 with the latest drivers. Below is the opera://gpu/ partial output. Of note is the "Problems Detected" section:

    Graphics Feature Status
    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Hardware accelerated
    Video Encode: Hardware accelerated
    WebGL: Hardware accelerated
    Driver Bug Workarounds
    clear_uniforms_before_first_program_use
    disable_discard_framebuffer
    disable_dxgi_zero_copy_video
    disable_framebuffer_cmaa
    exit_on_context_lost
    force_cube_complete
    scalarize_vec_and_mat_constructor_args
    texsubimage_faster_than_teximage
    Problems Detected
    Some drivers are unable to reset the D3D device in the GPU process sandbox
    Applied Workarounds: exit_on_context_lost
    TexSubImage is faster for full uploads on ANGLE
    Applied Workarounds: texsubimage_faster_than_teximage
    Clear uniforms before first program use on all platforms: 124764, 349137
    Applied Workarounds: clear_uniforms_before_first_program_use
    Always rewrite vec/mat constructors to be consistent: 398694
    Applied Workarounds: scalarize_vec_and_mat_constructor_args
    ANGLE crash on glReadPixels from incomplete cube map texture: 518889
    Applied Workarounds: force_cube_complete
    Framebuffer discarding can hurt performance on non-tilers: 570897
    Applied Workarounds: disable_discard_framebuffer
    Zero copy DXGI video hangs on AMD drivers: 623029
    Applied Workarounds: disable_dxgi_zero_copy_video
    Limited enabling of Chromium GL_INTEL_framebuffer_CMAA: 535198
    Applied Workarounds: disable_framebuffer_cmaa
    Accelerated rasterization has been disabled, either via blacklist, about:flags or the command line.
    Disabled Features: rasterization
    Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
    Disabled Features: native_gpu_memory_buffers

  • I have a screen capture but how do I post it?

    Stone the picture in a public storage site and post the link here.

    However I was referring more to a example link to a video with the problem.

  • Play the movie:
    https://theconversation.com/the-great-movie-scenes-hitchcocks-vertigo-63320

    Plays fine here. you sure you got h264 codec installed?

    opera://gpu/ log:
    http://pastebin.com/Cxeam15z

    opera://media-internals/ log:
    http://pastebin.com/yX18MzJV

    http://i.imgur.com/mV6Vo5S.jpg

  • Play the movie:
    https://theconversation.com/the-great-movie-scenes-hitchcocks-vertigo-63320

    No problems here on a Intel HD4600.

    Does opera://media-internals/ shows anything unusual when playing that video?

  • Well look here.

    http://imgur.com/a/gj0wz

    archangel000, do I have to manually install h264 codec? I would have thought the system would come with it.

    leocg, do I run the opera://media-internals/ line command in a separate tab while playing the video in a different one?

  • do I run the opera://media-internals/ line command in a separate tab while playing the video in a different one?

    Yep.

  • Same problem here.

    AMD 7850

  • leocg, I ran opera://media-internals/ I don't know what you meant by "unusual" but I put a screen capture here...http://imgur.com/7K38q6K. Thank you for your help!!

  • leocg, I ran opera://media-internals/ I don't know what you meant by "unusual" but I put a screen capture here...http://imgur.com/7K38q6K. Thank you for your help!!

    Now click on the entry related to the video you are playing and check for error messages or something like that.

  • I think I clicked on the right entry. Does this help?

    render_id: 16
    player_id: 0
    pipeline_state: kStopped
    event: WEBMEDIAPLAYER_DESTROYED
    url: blob:https://player.vimeo.com/47795c2a-2990-4217-9f46-7308659989d4
    duration: 614.62
    info: Audio codec: mp4a.40.2. Sampling frequency: 48000Hz. Sampling frequency(Extension): 0Hz. Channel layout: 3.
    found_audio_stream: true
    audio_codec_name: aac
    found_video_stream: true
    video_codec_name: h264
    audio_dds: false
    platform_pipeline_status_list: 9
    audio_decoder: WMFAudioDecoder
    debug: (Log limit reached. Further similar entries may be suppressed): Parsed video frame has DTS 792458us, which is after the frame's PTS 750750us
    video_dds: false
    video_decoder: GpuVideoDecoder
    height: 540
    width: 960

  • I think I clicked on the right entry

    It seems OK.

    What about opera:/gpu? Does it shows any error message?

    How the video behaves on Chrome or other Chromium based browser?

  • What about opera:/gpu? Does it shows any error message?
    How the video behaves on Chrome or other Chromium based browser?

    opera:/gpu log...http://pastebin.com/Z99wrCtW

    There might be a problem, starting with line 23.

    Video works flawlessly in Chrome and Vivaldi.

    By the way, the problem isn't limited to just this video. Any video from any website seems to display the green overlay.

  • There might be a problem, starting with line 23.

    The problem may be in lines 182 and 183.

    What happens if you disable hardware acceleration?

  • What happens if you disable hardware acceleration?

    That fixed the problem. Thank you, thank you, thank you!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.