Why does starting Opera produce an "Unlock Login Keyring" error

  • A few months' ago I installed Opera Developer after seeing a positive write up and I have used it on Ubuntu 1404 LTS on an occasional basis (Firefox is my basic browser) and it is very fast. I think I started around version 38 and with regular updates, it is now at 40.0.2280.0.
    It was only a couple of weeks or so ago (probably after one of the updates) that I first experienced this error message when clicking to open Opera :

    "The login keyring did not get unlocked when you logged into your computer. Password ..../ cancel/ unlock"

    I just hit cancel and Opera opens fine. Since I never use a login password, why would a request to start Opera suddenly have started producing this error a couple of weeks or so ago ?

    Is it connected with some requirement for Opera to use the Gnome Keyring Daemon ? I have always had this disabled at startup because it has a history of interference with GnuPG.

  • Opera tries to use the keyring, and use that to store its passwords (so that it is properly encrypted, and not just mock-encrytped).

    This is ~how I understand it works. Gnome keyring and many others unlock themselves by using PAM when you log in creating a session. Then lock when you lock the screen, unlocking again when you unlock. For that to work, the keyring and the login passwords must be the same.

    About your question, I'm not sure. It shouldn't just start changing how it behaves if you didn't do any changes. But what you can try is to use seahorse to change the password of your login keyring to blank. All your passwords will then be stored unencrypted, but you can't expect anything else when you don't use a password. Another way might possibly be to just move away (or delete) your keyring. On my computer it is this file:

    /home/velmont/.local/share/keyrings/login.keyring

  • Yes, Opera is connected with gnome keyring.

    Please use this flag when running opera to disable it:

    --password-store=basic apparently

    That should do.

  • Or indeed what rrzepecki said, making Opera use its own password store. Probably a better suggestion, especially if you just don't want to use your system keyring 🙂

  • Yes, Opera is connected with gnome keyring.
    Please use this flag when running opera to disable it:
    --password-store=basic apparently
    That should do.

    I have same problem on Linux Mint 17.As workaround, i have reinstalled Opera Developer package. Where should be inserted the quoted flag? There is an easier solution for this problem?

  • The good news is, that the Opera Developer browser at startup on linux platform no longer requires a password.

  • It asked me to create password when I synced my Opera (I created different password than Ubuntu user password).
    I think it is a security, because when I sync, it also restores my passwords for web pages (facebook, gmail, other sites, where I saved passwords).
    So, maybe, if my family members know my user password, they cannot use my Opera web page saved passwords if they don't know my keyring password(?).

  • This is too old. Open a new topic to discuss it in newest version if it's really necessary.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.