Opera Dev. 40.0.2273.0 gives me an unknown WAN IP in a normal window

  • Just as it says in the title. I'm in The Netherlands but if I go to a website that gives your IP I get:

    WAN IP address: 209.95.51.231
    Hostname: d15f33e7.setaptr.net

    This is in the US, here's more info: http://209.95.51.231.ipaddress.com

    Only Opera does this. Firefox and other browsers give my real IP. Is this a feature or a bug and am I in any danger? Another odd thing I've experienced is that sometimes when I visit google I get google.ae (United Arab Emirates). This is not an uncommon problems (google ignores geolocation) but in my case it may be associated with the the first (Opera?) issue.

  • Is VPN or Turbo enabled by chance?

  • VPN is never enabled in a normal windows, only in private mode. Turbo is not enabled either. edit I see VPN can be enabled in normal mode. But it wasn't so that wasn't the issue /edit

    I just noticed that when I use private mode with VP turned off I do get the right IP. In normal mode I tried to turn my extensions off one by one to see if one of them was the culprit. This had no effect and I still got the wrong WAN IP.

    So there's something about normal mode that causes this. I'd like an Opera developer to way in on this issue. It's kind of creepy.

    While writing this I think I've solved the problem. Here's how: I enabled VPN on the Opera settings page. This changed my IP as it's supposed to do. After disabling VPN I now get my real IP in normal browsing mode.

    What the heck happened here?

  • What the heck happened here?

    You probably had VPN or a proxy enabled by chance.

  • What the heck happened here?

    You probably had VPN or a proxy enabled by chance.

    How? I didn't make any mistakes I'm absolutely sure.

  • How?

    Well, i already saw reports about Turbo being enabled without it being clearly noticed because the check-mark wasn't visible.

    Maybe it was the case.

  • Well, i already saw reports about Turbo being enabled without it being clearly noticed because the check-mark wasn't visible.
    Maybe it was the case.

    Thanks but I never tried Opera Turbo and believe it's turned off by default. I would have known if I had enabled it soo something strange is going on here.

    I'd still like an Opera dev. to way in on this issue.

  • I'd still like an Opera dev. to way in on this issue.

    Well, this is an users'forum and although Opera employees may come here occasionally, you should not expect any answers from them.

  • I'd still like an Opera dev. to way in on this issue.

    Well, this is an users'forum and although Opera employees may come here occasionally, you should not expect any answers from them.

    Alright thanks for the help. Not important: I see that I said "way in". Ha! I meant "weigh in" of course.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.