Opera not letting me click buttons or links

  • Version: 38.0.2220.31 - Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit (WoW64)

    Just noticed this problem about a week ago. Most of the time it is like when I go to a place like ancestry.com and put in my name and pw and click the continue button, nothing happens. I fill out an online form, click submit, nothing happens. Website hyperlinks work about 50% of the time, some I can right click and open, others I can't.

    Kinda irking me now because I can't log into places that doesn't keep me steadily logged in.

    Any way to correct this problem? And advice would be greatly appreciated.

  • What extensions do you have installed? Does it work in a private window?

  • This is all that is listed in the extension area. And I just used ctrl + shift + N and it does not work in privacy window either

    Adblock Plus
    Version 1.12
    disabled
    Used by over 50 million people, a free ad blocker that blocks ALL annoying ads, malware and tracking.
    Visit extension's website
    Enable

    Gmail Notifier
    Version 0.6.4
    Multiple label and account notifier for Google Mail (Gmail)
    Visit extension's website
    Disable
    Options

    Hide from toolbar

    Allow in private mode
    Shortcuts for Google™ Products
    Version 1.1.4
    disabled

    Display all Google services in a single space-saving drop-down panel
    Visit extension's website
    Enable
    Youtube to mp3 converter
    Version 1.0.0

  • Try disabling the ad-blockers.

  • Adblock Plus Version 1.12 disabled as you can see from my post above, it is disabled 🙂

  • Adblock Plus Version 1.12 disabled as you can see from my post above, it is disabled

    And what about Opera's ad-blocker? Is it disabled?

  • Okay I went up top where the blue opera ad blocker is, went to ancestry to log in tried it enabled, in blue showing ads blocked, and greyed out show all ads, still can't click the sign in button, nothing happens.

    Would it just be easier to roll back to an earlier version of opera? Or uninstall and reinstall?

  • Okay I went up top where the blue opera ad blocker is, went to ancestry to log in tried it enabled, in blue showing ads blocked, and greyed out show all ads, still can't click the sign in button, nothing happens.

    Did you reload the page after have turned ad-blocker off? did you disabled all extensions while testing?

  • Actually, just out of curiosity I got rid of ever extension. Still does it, or should I say doesn't do it. Guess I will either try to uninstall and reinstall, or go back to firefox.

    Thx so much for you help, it is appreciated.

  • Well, at least on the home page the links start to work if i disable the ad-blocker. Don't know about other pages since i don't have an account on that site.

  • Click "Menu", and then uncheck "Opera Turbo" underneath "Extensions". I hope that helped, that was my issue, and I created this Account just to let you know LOL

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.