Search with Google / Copy

  • Wenn ich Text auf einer Webseite markiere, erscheint eine Sprechblase, die mir die Option anzeigt mit Google zu suchen bzw. den markierten Text zu kopieren. Dies passiert unabhängig von der Webseite und ich habe testweise sämtliche Plugins deaktiviert. Eine Option zum Deaktivieren dieses Features konnte ich bisher nicht finden.

    Am Besten kann man das wohl anhand eines Screenshots erklären:
    https://www.picflash.org/picture.php?key=XXFDX9&action=show

    Das ist extrem störend, besonders, wenn damit Eingabemasken verdeckt werden.
    Weiß jemand ob bzw. wo man diese Funktion deaktivieren kann?

    Zu meinem System:
    Opera 36.0.2130.66
    Windows 10

    Edit: Okay, das Feature scheint mit Opera 38.0.2220.29 entfernt worden zu sein.
    Da hätte ich mal noch 3 Minuten mit dem Posting warten können.

  • Sicher, dass das ein Feature von Opera war? Ich kenne ein solches Verhalten von Opera nämlich überhaupt nicht. Ich habe dagegen das Problem, dass sich Linktext gar nicht markieren lässt.

  • Das Verhalten kenne ich hier auch nicht, habe aber festgestellt, dass auf verschiedenen Seiten
    unterschiedliche Symbole auftauchen. Bei Blizzard im Forum z.B. dies, wenn ich etwas markiere: https://pl.vc/1c4rn1, oder Corsa Forum: https://pl.vc/1milft

    Scheint also abhängig von der Homepage zu sein. Unter swr1.de kommt z.B. "diesen Text vorlesen"

    @meersau
    wie meinst du das mit Linktext? Z.B. den Link im ersten Beitrag kann ich markieren, ist aber zimeliches Gepfriemel, ich muss etwas links vom Beginn sein, damit das Handsymbol zum senkrechten Strich wird. Geht das bei dir nicht?

  • Das habe ich auch auf OS X, Developer und Beta Version.

    Das nervt total, siehe das Bildschirmfoto:

    Bildschirmfoto

    Bildschirmfoto

  • Inzwischen scheint dieses graue Feld "Suchen | Kopieren" überall gleich aufzutauchen. Das ist sicher eine Einstellung des Browsers, nur wo abzustellen?

    Es ist auch inzwischen so, das die seitenspezifischen Popups beim Markieren zusätzlich eingeblendet werden, was einen unschönen Effekt ergibt. Das Foto zeigt eine markierte Stelle aus dem Corsa Forum jetzt: https://picload.org/image/rrwddodw/suchen.png

    Im Vergleich dazu siehe meinen Beitrag 3, wo noch der ursprüngliche Screenshot verlinkt ist, da sieht man nur die rote Einblendung: https://pl.vc/1milft

    Wäre das einen Bugreport wert? Oder kennt jemand die näheren Hintergründe?

  • Nachtrag:

    die graue Einblendung kommt definitiv von Opera. Wenn ich das Corsa-Forum mit Firefox öffne, und etwas markiere, kommt nur die rote Einblendung. Gesucht wird dann mit der in Opera gewählten Standard-Suchmaschine.

    Edith:
    bin jetzt doch fündig geworden, unter Einstellungen/Browser/Benutzeroberfläche:

    "Enable the search popup on selecting text" - deaktivieren.

    Warum das Englisch da steht, keine Ahnung. Baustelle?

  • In Opera Stable geht das derzeit nur per opera://flags/#search-popup

    bin jetzt doch fündig geworden, unter Einstellungen/Browser/Benutzeroberfläche:
    "Enable the search popup on selecting text" - deaktivieren.

    Gibts in Opera Stable (39.0.2256.48) nicht.

    Warum das Englisch da steht, keine Ahnung. Baustelle?

    Ja Baustelle, du benutzt Opera Beta oder Developer.

  • Nee nee, ich benutze Opera 39.0.2256.48, Developer oder Beta hatte ich noch nie in Benutzung. Ich habe zwar die flags freigeschaltet, aber aktiviert habe ich das ganz sicher dort nicht.

    BTW: in flags steht unter Search-Popups:
    Standard: aktiviert!

  • Dann mache doch mal einen Screenshot. Ich habe die Einstellung in Opera 39.0.2256.48 jedenfalls nur in Opera:flags

  • Gerne:

    https://pl.vc/1fqqoi

    Edit:
    sehe gerade, dass "Power-User-Einstellungen immer anzeigen" aktiviert ist. Aber auch wenn ich das deaktiviere, erscheint der englische Text noch.

  • In einem neuen Profil habe ich diese Einstellung jetzt auch. Es kann aber nicht Sinn und Zweck sein, dass bei jedem Update, das neue Funktionen bringt, man das alte Profil wegwerfen muss, weil sonst die neuen Funktionen nicht zur Verfügung stehen.

  • Ich habe hier immer noch das erste Profil, ich hoffe mal, dass bei mir bisher alle neue Funktionen angekommen sind. Obwohl, bei manchen neuen "Funktionen" würde es mich nicht sonderlich stören, wenn diese unter den Tisch gefallen wären :D. Vielleicht ist bei dir bei einem Update nur etwas schief gelaufen. Andererseits kann ich mich nicht entsinnen, dieses neue "Feature" in einem Changelog gelesen zu haben, sonst wäre dir das wohl aufgefallen.

  • Was sollte da schiefgelaufen sein? Schließlich funktioniert es mit einem neuen Profil ja. Das ist mit Sicherheit nur irgend ein Detail im Profil. Ich habe aber keinen Bock wegen dieser Kleinigkeit ein neues Profil zu verwenden, geschweige denn Ursachenforschung zu betreiben. Zumal über kurz oder lang eh ein Wechsel zu Vivaldi ansteht.

    Stand möglicherweise nur im ausführlichen Changelog und wurde überlesen, für unwichtig empfunden oder es war gerade jenes, dass man nur überflogen oder gar nicht erst gelesen hatte (kommt hin und wieder vor). Andererseits steht tatsächlich nicht immer alles in den Changelogs. Vom Entfernen der Lesezeichen-teilen-Funktion bin ich damals überascht worden.

    Ja ich habe da auch noch das erste Profil. Ist aber nicht so alt wie ein paar andere, die ich im Moment gerade nicht nutze. Ist alles die Folge des vor kurzem durchgeführten endgültigen Wechsels auf den neuen, inzwischen auch schon 1,5 Jahre alten Rechner.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.