Insecure connection problem

  • Trying to get connected in Opera browser running windows 10 64 bit,I live in an apartment block using their server,no problem using IE 11 or Firefox but as the server shows http: and not https I cannot connect as Opera flags it as an insecure connection,I have lived here for 2 years without any IT problems can someone help me to overcome this problem and connect sucessfully with Opera?

  • What exactly happens when you try to access the server? There is an error message?

  • I sign into my apartments account with my password and this gains internet access,I am able to open both Edge and IE 11 browsers without issues, however if I try to load Chrome/Firefox or Opera with my home page MSN.co.uk the curser just spins and the webpage does not load, when I then click on the address bar a message appears saying unsecure connection.
    The web address of the apartments server begins http and not https,I might add that this issue started just a week ago and my notebook pc with identical OP system Win10 and programes is not affected,I,m using Firefox browser without any problems on my notebook..............strange really as I have changed nothing on either pc,s.
    When the problem first started I did a virus/malaware scan and nothing showed up in the end I did a Win10 refresh hoping that would solve any problem unfortunately it hasn,t
    Thank you for your reply and hopefully you can help me resolve this issue

  • So you can't access any page using Opera?

    when I then click on the address bar a message appears saying unsecure connection.

    What exactly the message says?

  • At the very top of the screen after the menu button it shows http://www.msn.uk-gb
    In the address bar underneath www.msn.uk-gb the same BUT the globe is grey and when I click page information is says Unprotected connection.
    In the Google search box it says msn.uk-gb,s.... DNS address could not be found.
    Now I have just tried through the google search box to see if anything else is loading and yes some websites ARE loading up and some are not but the globe is still showing as Unprotected connection on each website even though I,m able to view some pages.
    I hope this helps and this problem can be sorted as I think the Opera browser is an excellent piece of kit.

  • As a follow up I loaded Opera onto my Asus netbook (Win 10 32 bit) and it loaded my MSN homepage without a problem (it still says in the address bar unsecure connection however) and I signed into my Microsoft account to view my emails which loaded fine but I cannot open any emails............strange-I then switched my browser back to Firefox and accessed my emails from there.
    Both my Laptop and Netbook are running Windows 10 the laptop is a 64 bit version and netbook 32 I don,t know what this actually means but it may be relevant.

  • "Insecure connection" there just means the data aren't encrypted to a level - https means "secure", encrypted. It's site dependent if it wants to communicate with your browser with the data "secure".

  • so why on one pc can I load it but not on the other?
    also why on my netbook does it load ok but I cannot open my emails?
    thanking you again for your help

  • At the very top of the screen after the menu button it shows http://www.msn.uk-gb
    In the address bar underneath www.msn.uk-gb the same BUT the globe is grey and when I click page information is says Unprotected connection.

    As should since you are visiting a non-secure page. What happens if you use https:// instead?

    In the Google search box it says msn.uk-gb,s.... DNS address could not be found.

    Does it work on other browsers?

    As a follow up I loaded Opera onto my Asus netbook (Win 10 32 bit) and it loaded my MSN homepage without a problem (it still says in the address bar unsecure connection however) and I signed into my Microsoft account to view my emails which loaded fine but I cannot open any emails......

    You seem to be mixing a lot of different issues here. So this topic is about you not being able to open pages? Or it's about Opera showing pages as insecure? or it's about you can't open your e-mails?

    Both my Laptop and Netbook are running Windows 10 the laptop is a 64 bit version and netbook 32

    Both run anti-virus, firewall or similar software? If yes, both run the same ones? Both connect to the internet in the same way?

  • An overall, successful connection process can be stumbled or perturbed at a variety of points along the way.

    When your computer contacts or visits a website, it doesn't route its data using the typed URL text of the address bar, it must instead use a numerical IP address for routing data onto the Internet. That IP number must be obtained from somewhere, either a list stored locally (a hosts file) or otherwise obtained from a special-purpose DNS server, either on your apartment server on the Internet. If an IP record is found for the requested URL text and communicated to the browser, the browser will attempt contact with the desired website's server using that IP address. If the website at that IP address normally uses secure https protocols for its communications, it will respond to the browser's contact attempt with an offer to the browser to negotiate the specific communications protocols that will be used thereafter to send its data. In your case, between the website and your browser sits the apartment's server, which is apparently unable to support secure https communications protocols. Depending on how the website server is coded, if the browser and site can only communicate via an insecure http protocol, the site will normally either refuse the connection request or respond to the browser request with feature or program access that may be limited in some manner.

    Different external 'default' DNS servers can be differently specified for different computers and different internal hosts files can contain different IP entries. Your ultimate Internet service supplier may supply their own DNS look-up services as default. Your local apartment server may even supply DNS results to your system DNS requests for various most-used websites. However, a given DNS server's records may have become corrupted or poisoned, compared with another server's, or a change to a website's IP may not have rippled into all the DNS servers in existence at the same rate. The point is that if DNS records aren't kept fully up-to-date and error-free on all the DNS servers, one DNS server might return a different IP address from another DNS server's IP response - or not even contain a record at all- for a requested URL text address. Consequently, a computer using one DNS server (or their own internal hosts file) may get a different IP address than another computer that contacted a different DNS server (or carries a different internal hosts file entry). That different IP address may result in slightly different website server code being offered up to one computer, compared with another - or even no connection at all.

    There are differences between browsers (and potentially even different bit-versions of the same browser) in how they negotiate and handle communications with https site-servers that for whatever reason can't establish a genuine https connection with the browser. If the negotiation process breaks down in certain ways, the browser and/or site may simply refuse to display the site. In other situations, depending on the details, a browser and https website might enable insecure http-grade communications instead, but perhaps limit that in some way in terms of what can be accessed. The limiting can be further complicated by the fact that some features of a site may be accessed by redirecting to yet other https sites, whereupon the entire connecting/negotiating process is repeated for those, and the chances for variations and screw-ups increase geometrically.

    Compounding all of this is the reality that many times, log-in communications with a given website (eg: MSN) isn't just a simple one-time connection, but instead consists of multiple redirected connecting actions through intermediate site servers, each of which must properly interact with the browser in order to get to the end of the chain.

    The first place to start might be to search both your computers for their hosts file, then open it in Notepad and see if there are any entries referring to MSN. Most modern computers typically have little, if anything, any more in their hosts files unless the user is employing them for ad-blocking or anti-malware purposes. The next place to look might be whether either computer has specified a DNS server beyond the typical default 'let the ISP provide the service' configuration.

  • blackbird71,thanks for your reply but my knowledge of host files is beyond my pc knowledge,however I have checked my laptop and the DNS server says"let the ISP provide the service" what do you suggest I should reset this to?

    leocg,
    in answer to your question about mixing up issues I am simply trying to explain and understand myself why I,m experiencing these problems.
    My initial enquiry was that upon loading the Opera browser on my main pc ie laptop I could not load my MSN uk homepage when my other browser IE 11 was opening it............I have now discovered that many other websites that I use are loading through Opera including one banking site but not another.I could understand if the same problem was showing in IE 11 browser but they are not,no issues whatsoever apart from the blasted ads.
    I then decided to see if loading Opera on my netbook would duplicate but it did not MSN UK loads up no problem and I signed into my Microsoft account to view my emails,my Outlook page opens but I,m unable to open up an individual message....using my default browser Firefox again no problem opens my messages.
    I have used the same connection through my apartments server for these tests.
    As I said earlier if both PC,s were showing the same problem I could understand it more.
    For security it is the same on both the Windows Defender as installed with Windows 10 operating system.
    My main pc my laptop is my main concern,I would like Opera {working properly of course} as my browser with IE 11 as standby,my netbook is fine with Firefox at the moment.
    I would like to thank you both for your help so far and hopefully these glitches can be sorted.
    Peter

    Thank you both for your help so far and hopefully these glitches can be sorted soon.

  • blackbird71,thanks for your reply but my knowledge of host files is beyond my pc knowledge,however I have checked my laptop and the DNS server says"let the ISP provide the service" what do you suggest I should reset this to? ...

    That's the typical setting for most users, and is generally satisfactory for them. You should check the netbook computer to see if it's set the same way. If so, then either there are differences between the two computers' hosts files or there is something else at work here. That, as @leog pointed out, might be something else that is between your browser and the Internet, such as AV, firewall settings, or similar. Initially, you are looking for software or settings differences that might contribute to the different browsing results between the two computers, even though neither one seems to work properly. That may help zero-in on what's wrong overall.

    Regarding the hosts file, it's a simple text file cross-reference listing of URLs and associated IP numbers. Normally for most users, it should be largely unpopulated with just some introductory textual remarks at the top. However, if a user, malware, or certain software has inserted entries into one of your computers' hosts file for various websites, the IP address associated with a listed URL will be used by the computer instead of it ever consulting the specified DNS server for such data. That could explain why the two computers don't seem to react to the same textual URL the same way, if the URLs don't both cross-ref to exactly the same IP number. It's just one more possible cause to try to eliminate, with minimal effort. If the hosts files on the two computers are the same, then that's not a cause of the problem.

  • OK I can report that BOTH my pc,s DNS servers say "let the ISP provide the service" so we can rule that out.
    secondly I,ve checked my HOSTS files and again they are both showing the same settings namely

       127.0.0.1 local host
       ::1       local host
    

    so this can be ruled out also.

    My security settings as far as I am aware should be the same as I am using Windows Defender to monitor my security although I have Malawarebytes and CC Cleaner installed also.

    Hopefully this will take us nearer to a solution....but then again it may have complicated it more LOL
    Thanks again for your help and please do not give up on me.

  • Following up on my earlier comments I have made a change to my DNS server settings and changed it to googles 8888
    8844
    This seems to have improved things a little,I am now able to load my MSN homepage,when I type in the google searchbox www.msn.co.uk it changes this to www.msn.com/en-gb and as previously mentioned does not connect HOWEVER if I then manually change the search bar to www.msn.co.uk it works although in the search bar underneath it is still showing www.msn.com/en-gb.Also the curser spins for a long time even though the page appears fully loaded also when I click to sign into my microsoft account to view emails a new window loads saying "Sign into your Microsoft account" but again nothing happens the curser just keeps on spinning without connecting.
    I hope that you are happy with me using googles DNS settings if not let me know please.

  • When I visit the msn.co.uk page here (in the US) by manually entering the URL using Olde Opera where I can easily control and monitor website URL re-directions, the entered page immediately pushes an auto-redirect to the msn.com/en-gb page. If it is trying to do the same at your location, it sounds as if your browser isn't auto-redirecting as it should or the redirection destination information isn't coming back to the browser, since you seem to have to manually enter the msn.com address to get even a partial connection to occur. Also, it appears there is something on the msn.com page that still needs to load into your browser whenever your cursor continues spinning. Other links on the msn.com page result in re-directions, sometimes multiple ones, which is very typical of Microsoft website behavior in recent years. So it's possible that the link to sign into your Microsoft account results in a redirection that is failing, hence nothing seems to happen.

    I'm also wondering if you are receiving re-directions to https pages in attempting to read mail or perform log-ins and those are perhaps failing because of your apartment server only handling http protocols? Apparently because I have no MSN/Microsoft account and perhaps because I'm state-side viewing a UK page version, I don't receive a log-in or eMail offer on the msn.com page. Consequently, I can't explore anything in that realm.

  • Thank you for your help,it seems windows 10 is still being developed and glitches need sorting,I have uninstalled Opera until it seems more stable and continue with IE11 where everything is still functioning fine.
    You can close this thread if you so desire.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.