v37 broke Foscam plugin

  • Opera v37 automatically upgraded (from v36) and now my Foscam camera plug-in does not work and will not install. The plug-in (.exe file) does install on Windows 10 but had no affect on Opera, does not show up as an Opera plug-in.

    How can I either:

    • Downgrade to Opera v36

    • Get the Foscam camera plug-in to work with Opera 37

    Thank you

  • If it's a npapi plugin then it will not work in latest versions of Opera nor on latest Chromium based browsers as support for npapi plugins has been dropped since a while ago.

    The vendor will need to release a ppapi version of the plugin or allow to access the camera using html5.

  • Yeah it broke the NPAPI plugin. I also have an older Foscam that is no longer supported by firmware updates.
    Here's what I did: Downloaded a version of 36, unplugged the network cable (so it wouldn't auto-update after installing), installed 36 as a stand-alone/USB on my data drive (as opposed to my OS drive where the updated 37 is installed), closed it and renamed the opera_autoupdate.exe to opera_autoupdate.lexe.
    I now use that install just for the camera.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.