:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

/usr/lib/opera/plugins

  • Good morning.
    I have installed opera-stable_37.0.2178.32_amd64 on ubuntu 15.1

    It works, but it doesn't read any flashplayer plugin.
    I have installed the most recent flashplayer version and it works on other browsers (Firefox).
    In opera, typing opera://plugins, I can see Adobe Flash Player - Versione: 20.0.0.267 - Shockwave Flash 20.0 r0 enabled.
    I checked and it did not exist the directory /usr/lib/opera/plugins
    I created it by typing " sudo mkdir /usr/lib/opera/plugins" and copied in it the libflashplayer.so file.
    It doesn't work anyway.

    Any suggestion?
    I like Opera and I would not like to give up with it.

  • Install pepperflash-nonfree. Opera - and other chromium based browsers - does not use the same type of plugin as Firefox.

  • I'm using Mint 13 (Precise), I keep getting the "Update Flash" thing, it just takes me to the adobe npapi page, useless. pepperflash-nonfree is not in synaptic, is there a repo I can add? Or, is there a way to suppress the nag? I have thousands of customers out there with our Linux distro (Based on Mint 13 and 17) who are gonna be switching if I can't get this ironed out.

  • Hi bolondig,

    sgunhouse is correct. Our friend, jayaguru-shishya, had a devil of time doing so too until he installed Ubuntu 16.04. I, too, was able to install pepperflashplugin-nonfree in Xubuntu 16.04. Who knows? Maybe you're good to go with Pepperflash right now using Wily --maybe not. You've got two more months of support with Wily Werewolf. Support ends for 15.10 in July.

    The command to install pepperflashplugin-nonfree is this:

    sudo apt-get install pepperflashplugin-nonfree

    And here's the thread in Opera where we discussed this matter in more detail. This thread began a couple of weeks ago:

    https://forums.opera.com/topic/14941/opera-comes-with-flash-pre-installed

    Good luck, bolondig! I hope this thread helps. And do consider adding NoFlash, which is found in Opera's Store, when you don't want Flash to be active.

    perknh

    P.S.

    After running:

    chrome://plugins

    in your omnibar/search bar, you should see this:

    Adobe Flash Player
    Version: 21.0.0.216
    Shockwave Flash 21.0 r0

  • I was taken to this link when I asked, "How to solve Digital Rights Error Your web browser is missing a digital rights component. In the address bar, go to opera://plugins and ensure Widevine Content Decryption Module?"

    Can anyone help solve my problem?? Going to opera://plugins results in two items which describe Disable of Adobe PDF & Flashplayer. Search of plugins yields-- Nothing found for "Widevine"". Where is this plug-in????? TIA

  • Hi q99h,

    What browser are you using? What plugin are you looking for? What happens when you enter this command in Opera's Omnibox

    chrome://plugins

    ?

    Can you copy and paste this information for us?

    perknh

  • Correction for q99h,

    What distribution are you using --Ubuntu 14.04, 15.10, or 16.04? I meant to ask about your distribution --not your browser. (I know you're using Opera!) My apologies, q99h.

    perknh

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.