Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[OperaMail 1.0 build 1044] Writing Logfiles of SMTP communication?

  • Hi,

    Last week I updated Opera Mail upon suggestion that there was a new version. Since then I cannot send mails via my employer's SMTP server (uses authentication). There is no error message, just the mails being stuck in the Outbox. Other servers work fine.

    Without success, I have been trying to find any logfile. Does anyone know how to activate writing of a logfile? Up to version 12 of the old mail client inside the browser it seemed straight forward, but right now I am stuck. It would be really helpful to have some type of error message to report to our IT guys.

    Thanks in advance for any input,

  • There is a file in the mail directory named accounts.ini, it is a text file and can be edited in a text editor. Find the section for the account in question, there will be a couple of lines for log files (one for incoming mail, one for outgoing). Set the line for outgoing log file to a valid location - Mail will create the file, but the path must exist and be somewhere you have permission to create files. Of course, only edit the file while Mail is closed. Next time you try to send a message, the file will be created.

  • See

    But, retype your username and password on the servers tab in the account's properties.

    Also, check firewall and anti-virus email scanner settings.

  • Thank you both! Actually, I had tried this already several times, but obviously wrong. Out of laziness, I wanted to write to C:\ which is obviously blocked. In the home folder I now do have them 🙂

    Unfortunately, the SMTP logs are completely inconclusive, at least to me 😞

    10/05-2016 10:56:35 SMTP OUT :
    10/05-2016 10:56:35 SMTP IN :

    Does anyone have a clue?

    About firewall settings etc.: There was no change, only the OperaMail update. Before that mails were send. Actually sending to other servers with Opera works and other mail programms can send to the server in question as well. I have the assumption that it is somehow linked to SMTP authentication, but I am not sure about that...

  • For the log, you're immediately disconnected. You don't even get to the authentication part.

    What port are you using for the outgoing server? It should be port 465 with TLS checked or port 587 with TLS checked. If you're using port 25, even if it worked before, change it.

    Try setting the authentication back to "auto" if it's not at "auto".

    Did you retype your username and password as suggested?

    About firewall settings etc.: There was no change, only the OperaMail update.

    If you're not using the built-in firewall, maybe you can clear your program exceptions for Opera and reallow when Opera tries to connect.

    Download the new Opera Mail manually launch it, click "options", set "install path" to your existing Opera and upgrade just to rule out any program file corruption, even if you're only having issue with that one server.

    Check your time, time zone, date and daylights savings time settings to make sure they're correct.

    Finally, close down Opera Mail and edit operaprefs.ini (not operaprefs_default.ini). See "Menu -> help -> about Opera Mail" for the location. In that file, under the [Security Prefs] section (add it if it's not there), set (add them if they're not there) the following.

    [Security Prefs]
    Enable SSL v3=0
    Enable TLS v1.0=1
    Enable TLS v1.1=1
    Enable TLS v1.2=1

    If it still doesn't work, set TLS 1.2 to 0. If that still doesn't work, set TLS 1.1 to 0. Keep TLS 1.0 to 1. You shouldn't have to set SSL v3 to 1, but you can try it if all else fails.

    If none of that works, put the settings back to the above and downgrade. Then, see if it works again (messing with the TLS settings if you have to).

    If you have to downgrade to get things to work, the security update in the new build probably broke something with that particular server (as in, the server is using something outdated etc. or there's just a bug in the newer Opera Mail).

  • You made my day, burnout!

    In the meantime, I had a remote session with an administrator and we already suspected that the security prefs were the critical point because KMail only worked when choosing SSL but not with TSL. After that I read your post and then new where to find these settings in Opera Mail (everything else you mentioned in your mail was fine). The big suprise was that the settings written down in my operaprefs.ini were:

    Enable SSL v3=0
    Enable TLS v1.1=0
    Enable TLS v1.2=0

    which looks like a very bad setting. I added the line for TLS v1.0 and set all TLSs to 1. Now mail sending works again!

  • I added the line for TLS v1.0 and set all TLSs to 1. Now mail sending works again!


    which looks like a very bad setting.

    When a setting isn't present, it causes Opera to use the default value for that setting. In the case of v1.0, that should be 1. You can remove all the settings from the file to have Opera use the defaults and see if things still work. When the settings are present, that usually means the user set them (unless of course Opera added them as an override in a past update).

    The default settings in the latest build should be v3=0, v1.0=1, v1.1=1 and v1.2=1. But, in the past 1.1 and 1.2 were off and v3 might have been on. 1.1 and 1.2 were off as they caused problems. v3 should be off now as it's insecure.

    Since 1.0 was already defaulting to 1, it sounds like the server needed 1.1 or higher or at least had some problem negotiating down to 1.0. Or, it was something else.

    Glad you got it working.