Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Mobile 12.10 for Android can't "see" or save Downloads to sdcard1

  • sdcard1 is how my current android phone sees the real MicroSD card.

    Opera can't see it or navigate to it if I want to download something to it. The Save prompt comes up. I choose Other... and try to navigate to it but I cannot save to my MicroSD card. All other file browsers see the folder and can navigate inside it. After selecting Other... to download the file, Opera initially shows this.



    In the directory listing above, there should be this also:


    ...but for some strange reason Opera doesn't show sdcard1 (my real MicroSD card) at all. And there is no way to navigate to it.

    mnt doesn't contain my sdcard if I navigate inside it (but it did in a previous android phone). I guess they changed things. I have no luck now. sdcard0 isn't actually an sdcard at all; it is the phone's internal fake sdcard (android is a nightmare with this terminology). If I try to navigate to the parent of this folder, Opera returns me back to the Save prompt (!). There is no way to win. Can someone please try to help. I simply cannot continue using Opera Mobile 12.10 if I can't save Downloads to the MicroSD card. I tried later versions of Opera and hated them (many features were taken out. I think it was because of the move to Webkit) so I can't do that either. Unless things have changed since then?

    Thanks for reading.

  • On my ICS tablet, sdcard1 is actually mounted inside sdcard0, so for me it's /storage/sdcard0/sdcard1/ ... doesn't make sense to me, but Opera can find it.

    On desktop systems you'd be able to type /storage/sdcard1/ manually and it would work ...

  • sgnunhouse,
    For me the sdcard0 is definitely a separate entity to sdcard1 so I can't do that.

    I have seen other web posts with the same problem I have. No real solutions yet though. I'd love to know the technical reason why things are like this. I would have thought navigating directories would be 'standard' stuff and easy to do. I'm not sure why certain things are hidden or can't be navigated to when every other app I used has no problems.

  • My huawei 4.1 has a similar set-up. I save things internally, then cut&paste to the SDcard in a file manager.
    I have trouble uploading using Opera classic too, the item has to be on the internal memory to be uploaded.

  • Come to think of it, it may just be the security settings in Android. I can let apps 'test secure storage' or not... I might have a fiddle in the jellybean settings to see if it changes things.

  • I fixed it. Android 4.1.2:
    Settings > Storage > Default Write Disk > SD storage

    This setting was changed from USB Storage to SD Storage.
    Now the (real) MicroSD card is seen as **sdcard0 **instead of sdcard1, and Opera can 'see' it. Opera still doesn't recognise sdcard1, but I'm happy with this solution since I don't care to save stuff to the internal memory. I'm still in-the-dark as to why Opera isn't 'normal'.

    The fix was far easier than I thought.
    Not sure if I changed this setting in my other Android phone since I don't have it with me now. The only downside is some apps that I installed won't work now since they were installed to the internal memory which is now sdcard1 instead of sdcard0, but I'll reinstall them to fix things.

    I should probably make a note to change the Default Write Disk to the (real) MicroSD card (whatever it may be called) early on after getting a new phone (before all the installations happen).