Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 12.18

  • My installation of 12.18 has stopped launching Flash for one particular site, It worked fine after update from 12.17 until two mornings ago - now the page is rendered OK but there's a space where the flash popup should be. The contact person at the website says there have been no changes to the site recently.

    The flash installation is .306 ie. latest. The last time I used it successfully for the site in question, I also had a copy of Realplayer open.

    Other sites such as Youtube, and another church network mcnmedia launch the plugin OK, though the churchservices guy says they use a more recent edition of jwplayer than mcn.

    I'm running Windows Vista 32bit on an old Amilo laptop. Never had an issue with the problem site using 12.17.

    Any suggestions most gratefully received!

  • Confirmed here.
    Woks fine in all my other browsers, but as you say, no sign of the plugin loading on 12.18.
    Changing the site preferences seems to make no difference.

  • Thanks Dave, good to know it's not something on my machine.

  • It's probably something to do with the JW Player they're using.
    It doesn't produce the normal menu when right clicked that YouTube videos and others give.

  • @winterling, also and many many sites with weird domain prefixes :

    You need to manually download
    rename it to public_domains.dat
    and copy it over to C:\Program Files\Opera x64\defaults or wherever you installed Opera 12.18.

    This is an ancient bug introduced around 12.15. Opera people first forgot to bundle this file with 12.15/.16/.17 x64 builds, and now its gone from both 12.18 x86 and x64 builds.

    Without this file for example wont work. It has something to do with security (Cross-Origin Resource Sharing) and without it a lot of sites javascript cant function throwing security violations.

    Other than that it appears to be a solid build. 12.17 had totally broken openssl when tls 1.1/1.2 was enabled resulting in constant crashing. This one seems stable.

    Personally I think it might of been someones personal pet project/parting gift before being laid off in face of Chinese acquisition, for which I am extremely grateful. I had nightmares about decompiling Opera in IDA and manually binary patching newer version of openssl as my last ditch effort to use this great product in face of ECSDA gaining popularity.


    those icons are fonts
    needs to be enabled, and browser needs to be able to download appropriate webfont file from the server

    btw: all of a sudden Reddit stopped working for me on opera today. I am logged in, but cant upvote, comment or even request password reset. I thought it was 12.18, but checked again on 12.17 and its the same, can someone confirm?

  • ok W T F, how do you post links with underscore ??? 😕


  • Yes, it's really annoying, I don't care what @joshl and others who try to justify the use of the stupid markdown system here say!
    Thanks very much for that, but the videos are still not working on
    Should this have fixed them?
    The videos on do seem to be working.

  • Dave, it's not for me, it's simple. Angles, for example. 😛

  • @davehawley

    opera doesnt support hasFocus, but there is non generic fix in browser.js

    		document.hasFocus=function(){return !document["hidden"];}
    		log('PATCH-1152, Google sign-on - fake hasFocus method');

    why its not generic I dont know, pretty stupid 😕

    here is a fix for you, make a file called whatever.js, put it in userjs directory:

    // ==UserScript==
    // @name blah
    // @version 0.1
    // @author Rasz_pl
    // @namespace
    // @description blah
    // @include			**
    // ==/UserScript==
    document.hasFocus=function(){return !document["hidden"];};

    works like a charm, you are welcome 🙂

  • It certainly does!
    @winterling will be delighted I'm sure!
    I take it this will fix any site with the same issue, not just
    I hope spammers don't harvest your e-mail address from that code BTW!

  • no, its only for this one site, you could change it by leaving only "*", but this is the first time I ever encountered hasFocus in ~13 years of using Opera, so I wouldnt sweat it. I would rather message admin of that site and tell him to remove it. Its in the code, but I dont think its even used, opened this site in Chrome and there is no difference between browser having focus or not = another case of clueless web designer making something non standard and broken.

  • Thanks again!
    You haven't got a fix for the Facebook search field now being mis-placed have you?!

  • You haven't got a fix for the Facebook search field now being mis-placed have you?!

    Actually, I already do.

    Make a CSS file containing the following:

    ._50tk, ._2t-e {
        display: flex;
    ._2t-e, ._50tm {
        flex: 1;

    Then set this file as the custom style sheet in site preferences for FB. Of course this solution may break when they make changes to the site again, but we'll see. 😉

  • A small fix – the first line of the CSS should be:

    ._50tk, ._2t-e, ._2t-f {
  • Thanks for the correction, that explains why the log off icon was missing in the first version!
    So good to see the search field back where it should be, you sir, are a genius!

  • Email removed from here anyway ...

  • Good update... I is still usin Opera 12.18...

  • i cannot save ebay passwords anymore, there is no "save" popup after i have entered them.
    also my saved ones from before are not offered, the yellow border is missing.

    anyone same experience? can the save be triggered somehow manually?
    would be immensly annoying if i would have to enter this every time.

    rest of the sites work so far..

  • Go into the password manager, search for "ebay" and delete all the entries.
    When you next go to the site the password save should be offered again.
    Be aware that not all sites' login pages work with Opera 12's password manager now.

Log in to reply