Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 12.18

  • Yes, it is very much appreciated.
    Presto Opera is still the best browser ever made in the eyes of many people, especially those who appreciated its almost total personal user customisation facilities.
    The reasons for dropping it are well documented and completely understandable, but it was still a very sad day when it was seemingly abandoned for what many saw as an inferior substitute.
    Thank you so much for keeping the security and compatibility issues of its die-hard users still in mind, I can't imaging the developers of say Google Chrome ever doing that!
    :cheers:
    With regard to the security settings, thanks for all the advice guys, it sounds as if it will be fine left as it is.
    And I still haven't had any more unexplained sudden shutdowns (touches wood)!
    🆙

  • Sorry, back again!
    As this relates only to Opera 12.18 I didn't want to start another thread, but can anyone remember how you get rid of that extremely annoying (and now completely unnecessary IIRC) popup that says "click to activate and use this control" on plugins on later versions of Presto Opera?

    I have the xa-nocta batch file and associated scripts which I always used to use to get rid of the bloody thing, but that no longer works on more recent versions. There was a hex edit solution as well IIRC, if we're allowed to mention such things!
    I think there was an extension too, but I don't really want to use that as IIRC it only worked for YouTube videos.

    The annoying thing is that I'm sure I did it for 12.17, but I now can't remember how as it's so long ago!
    It doesn't seem to be a problem with the 64bit version of 12.18 BTW (I use both 32bit and 64bit versions on different operating systems).
    Anyone any ideas to jog my memory?
    🙂

  • There was a setting presuming you aren't using Turbo…

    I'm on my tablet now and can't look, but it should be in opera:config somewhere.

  • This isn't anything to do with the plug-ins only on demand setting.
    It's to do with the wretched Eolas patent nonsense, which has now been struck down.
    For some reason Opera never seem to have removed the code to prevent plug-ins running automatically, even though the patent hasn't applied since 2012.
    🙂

  • I was thinking about that Eolas thing yesterday, but I have yet to see it happen in 12.18 x86 (testing Flash), and I couldn't recall doing it for 12.17, so I thought that somewhere along the line that Opera itself finally added the "capability." After all, that lawsuit, or whatever it was, was concluded years ago.

    Can you give me an example page?

    It was always a patch (at least that I recall), never an opera:config setting (that's way too easy).

    All that said, I do see now that my 12.17 Opera.dll had two bytes in it changed from the original, but I have no documentation of why that is all this time later. I thought the Eolas patch (I used xa-nocta too, at least for a while) changed more than two bytes.

  • Hmm, just looked at opera's help: site http://www.opera.com/help and there is presto along with all the other products. I thought presto was long forgotten. What could be the meaning of this?

  • @rseiler
    Any YouTube video shows it for me, presumably assuming that auto play isn't enabled.
    Just hover the cursor on the video, and a "Click to activate and use this control" box pops up next to the cursor.
    The fix did involve changing just two bytes, xa-nocta did that for you if it was a version of opera.dll that it knew about, but it hasn't worked for a long time, since the early versions of Opera 12 in fact.
    There were some manual hex editing solutions around, which may well be what I used on 12.17, but the opera.dll on 12.18 seems to be completely different, with none of the hex vales matching at the same locations, so I wouldn't know where to start to find the places to make the two changes. It was just changing two 00 bytes to 01.
    🙂

  • Yes, that's what my two bytes were too, so we both must have done it manually. Only problem is that my.opera.com, which is where the blog was that explained how, is gone. But as you suggest, the patterns didn't stay the same from build to build, so that probably wouldn't be much help now.

    Even with Autoplay off, videos autoplay anyway, so I'm not sure what's going on with Youtube. But I went to other sites too, where videos don't autoplay (like charlierose.com), and still didn't see Click to activate. I'm a bit puzzled.

  • This is very strange!
    The Flash videos on charlierose.com don't trigger the popup here, but all YouTube videos do!
    I'm seeing the popup on QuickTime videos too. If you have QuickTime installed, have a look here and see if you get the popup when you hover the cursor on the video at the top of the page.
    🙂

  • I do see it here:
    http://www.chemgapedia.de/vsengine/help/en/flash

    Hmm. I don't get any 'click to activate' message there with a largely 'stock' 12.18 USB-on-harddrive install and Flash 20.0.0.206, though I do seem to have to click twice on the graphic's play button (>) to get the sphere-blocks to move the first time after a page reload.

  • It seems there's some other wacky variable to Eolas, but it's good that it's mostly not coming up rather than the opposite.

    @davehawley, I looked at the DLL, and it follows a predictable, if not exact, pattern as compared to 12.17, so you should have success.

    Search: 89 45 0c 3b d8 75 e8 8b c3 5b 5d c3 8b

    You'll find that puts you in the right area, and the work to do shortly follows it.

    I would change these two bytes: 6637cf and 6637e4. I don't have many sites on which to check it, but doing that at least eliminated the extra click necessary on the last site that I mentioned.

  • opera:config#Multimedia|AllowAutoplay perhaps?

    Youtube videos (and that Wendy's ad) autoplay here in 12.18.

  • Only problem is that my.opera.com, which is where the blog was that explained how, is gone.

    I believe you can still find it via the web archive.

    Who are those Eolas anyway?

  • @rseiler
    Thank you so much, that worked perfectly, I now have no more annoying prompts popping up!
    :cheers:
    I couldn't find that string of values you mentioned, but making the two changes as the addresses you gave did the trick.
    I'm assuming that the 64 bit DLL is completely different, but for some reason the 64 bit version of 12.18 doesn't seem to have the problem anyway.
    Much appreciated, I would never have found that myself!
    🙂

  • Hi guys,I'm using Opera 12.17 and Eset Smart Security 8.

    Recently I updated ESS to v9 and started to get these "Security Issue" notification While using opera on every single website, some websites give bunch of these and I've to click, click, click, ... very annoying.

    http://i.imgur.com/ZynJbzw.png

    http://i.imgur.com/hogHNQ1.png

    I updated to Opera 12.18 and still getting these pop-ups.

    How to get rid of these annoying pop-ups ???

    Thanks.

  • On that second tab, check the Remember my choice box and click Approve. Either that, or tell Eset not to scan secure pages. The warning looks the same as the one I get in Mail - your antivirus is acting as a proxy, and Opera is warning you that you have a potential "man in the middle" situation going on because the certificate is from Eset, not the actual website. (Not certain, but you might end up approving the certificate for every single website you normally visit. If so, I'd change the settings in Eset.)

  • Yes, I've to approve looooots of certificates, and for some websites I've to approve again and again even I checked remember.

    But I use Opera 35, Chrome, Firefox and Pale moon and only Opera 12 is giving me these issues, I mean it's something with Opera if I can adjust or alter something in Opera settings to prevent these warnings.

    I really don't want to mess with the antivirus as other browsers have no issues and I can't let go of Opera 12.

  • I'm also having another issue with Opera, some website's icons are missed up when opened in Opera ex,
    www.netvibes.com

    In opera
    http://i.imgur.com/CCh0fGu.png

    In other browser
    http://i.imgur.com/IWm2vq3.png

    Any solution for this ?

  • That looks like a font problem, some of the symbols on the page like the down arrows are being mis-rendered.
    Try masking as IE or Firefox using the site preferences.
    🙂

Log in to reply