Why can't new Opera locate legacy (NPAPI) flash plug-in?

  • Hi there,
    I had the previous, and the most recent version of "legacy" Opera, that was 12.17, you know. It's working fine and was used to locate all the plugins with no problem. Then i decided to "try" new-generation Opera, Opera 34, but "portable" version by downloading from portableapps.com. Note that i have Windows 7 SP1 64-bit.

    I had many problems such as:

    1. Opera 34 (portable edition) can't locate existing NPSWF32.DLL (NPAPI Flash Plugin) either from "C:\Windows\SysWOW64\Macromed\Flash" and also from "Program Files" folder.

    2. The file-folder structure seems to have been changed roughly, there's no effect on putting existing NPSWF32.DLL flash plugin file to ".....\Opera\Program\Plugins" as "Program" folder no longer exists on the path of version 34?

    I only have 3 folders named "34.0.2036.25", "Assets" and "Profile" and no plugin-related folder is located in them. What is the local plugin path of new Opera 34???

    1. Font rendering is bad when compared to latest Firefox 4x series. It's blurry on address bar and not clear on webpages. Disabling HW Acceleration doesn't help.

    I didn't like new Opera, as legacy versions were really good.

    Thanks in advance!

  • Opera is based on Chromium now. When trying to figure out how to do something in Opera, you can search for how to do it in Chromium or Chrome.

    Edit the Opera shortcut (it's a shortcut to launcher.exe) and add the command line option to search for plug-ins in a certain directory:

    "C:\Program Files (x86)\Opera\launcher.exe" "--extra-plugin-dir=C:\Users\user\test"

    In Opera though, type opera://flags/?search=npapi in the address field and hit enter. There you can enable support for NPAPI plug-ins. But, Opera and Chrome are removing support for NPAPI, so sooner or later, NPAPI plug-ins won't be supported at all.

    You can type opera://plugins in the address field and press enter. There you can enable disable individual plug-ins.

    Now, or flash specifically, you don't need to do this. You just goto adobe.com and download flash. It should install the PPAPI (not NPAPI) version of flash that Opera should automatically recognize.

    Think of opera://flags like opera:config

    For the font, try disabling direct write in opera://flags. Not sure if disabling hardware acceleration alone will help.

  • Thanks for your helpful response, appreciate. I've done what you suggested, however:

    Opera is based on Chromium now. When trying to figure out how to do something in Opera, you can search for how to do it in Chromium or Chrome.
    Edit the Opera shortcut (it's a shortcut to launcher.exe) and add the command line option to search for plug-ins in a certain directory:
    "C:\Program Files (x86)\Opera\launcher.exe" "--extra-plugin-dir=C:\Users\user\test"

    I did that. I put NPSWF32.DLL into "Flash" folder under "OperaPortable" folder as subfolder, then I created a shortcut to launcher.exe like this:

    "C:\Users\myusername\Desktop\Opera 34 Portable\OperaPortable\App\Opera\launcher.exe" "--extra-plugin-dir=C:\Users\myusername\Desktop\Opera 34 Portable\OperaPortable\Flash"

    I launched Opera, but still it failed to recognize NPAPI Flash file.

    The funny thing, it finds some other NPAPI-based other plugins such as PDF, Office Plugins, Windows Live plugins, 6 plugins at total, but it fails to find many other plugins, whereas latest Firefox (even portable version) works flawlessly. Is there somewhere in registry that i have to specify for Opera to find plugins that i want?

    In Opera though, type opera://flags/?search=npapi in the address field and hit enter. There you can enable support for NPAPI plug-ins. But, Opera and Chrome are removing support for NPAPI, so sooner or later, NPAPI plug-ins won't be supported at all.
    You can type opera://plugins in the address field and press enter. There you can enable disable individual plug-ins.
    Now, or flash specifically, you don't need to do this. You just goto adobe.com and download flash. It should install the PPAPI (not NPAPI) version of flash that Opera should automatically recognize.
    Think of opera://flags like opera:config

    I've also checked this before. Opera://flags shows "Disable NPAPI plug-ins: Disabled (default)" which means NPAPI has to be detected by Opera, but it's still not found.

    I'm lost here.

    For the font, try disabling direct write in opera://flags. Not sure if disabling hardware acceleration alone will help.

    Thanks', i'll try that if it helps.

  • Support for npapi plugins has been disabled in Chromium so Chromium based browsers also lost (or will lost when start using a recent version of Chromium) support for those plugins.

    For now it seems that some npapi plugins may still work in Opera but sooner or later all of them will stop working.

  • then I created a shortcut to launcher.exe like this:

    If you want to test to see if that command-line option at least works, try putting a different plug-in in the folder. But, I guess that won't help if the "Disable NPAPI plug-ins" being disabled doesn't re-enable NPAPI support.

  • then I created a shortcut to launcher.exe like this:

    If you want to test to see if that command-line option at least works, try putting a different plug-in in the folder. But, I guess that won't help if the "Disable NPAPI plug-ins" being disabled doesn't re-enable NPAPI support.

    As previously said, other NPAPI-based plugins are found just fine, but not NPSWF32.DLL, which represents Shockwave Flash Plugin. Is it a specific problem related to Flash along with detection of Opera?

  • Is it a specific problem related to Flash along with detection of Opera?

    Opera uses ppapi flash plugin.

  • You will want to use the PPAPI version of Adobe Flash Player, which you may find here.

  • As previously said, other NPAPI-based plugins are found just fine, but not NPSWF32.DLL

    Yeh. It just wasn't clear from your post whether it found some of the others *in that subfolder*. As in, it wasn't clear whether or not the command-line option was even working.

  • You will want to use the PPAPI version of Adobe Flash Player, which you may find here.

    Is there a download location for PPAPI-based Flash player using xcopy placement like NPSWF32.DLL does? I mean, just drop file (PPAPI plugin file) to plugin folder WITHOUT using Adobe's installer?

  • As previously said, other NPAPI-based plugins are found just fine, but not NPSWF32.DLL

    Yeh. It just wasn't clear from your post whether it found some of the others in that subfolder. As in, it wasn't clear whether or not the command-line option was even working.

    Sorry for that. The other plugins were found even without using command-line swith. Hope it clarifies.

  • Hi guys,
    I tried downloading PPAPI (Pepper Flash) from here:
    http://effect8.ru/soft/media/adobe-flash-player-portable.html

    And placed 64-bit .dll and other files here:
    C:\Users\username\Desktop\Opera 34 Portable\OperaPortable\App\Opera\flashplugin\x64\

    Finally, tried launching Opera Portable using that command-line switch:
    "C:\Users\username\Desktop\Opera 34 Portable\OperaPortable\App\Opera\launcher.exe" "--extra-plugin-dir=C:\Users\username\Desktop\Opera 34 Portable\OperaPortable\App\Opera\flashplugin\x64"

    But still Opera even fails to find PPAPI flash...! No luck!

    Am i missing something?

  • Is the 32-bit ppapi flash dll in the extra plugin dir? It needs to be as Opera is 32-bit.

  • Is the 32-bit ppapi flash dll in the extra plugin dir? It needs to be as Opera is 32-bit.

    I tried both 32-bit and 64-bit ppapi flash dlls to the corresponding folder. But Opera still can't find the Flash file. What else should i do? Is this a problem for Opera Portable or another command-line switch i need to use to force proper PPAPI plugin detection for flash?

    Thanks a lot.

  • Is this a problem for Opera Portable

    Don't know for sure, but you can test. Download Opera from opera.com, launch the installer, click "options", change the "install path" to a folder on your desktop, change "install for" to "Standalone Installation" and install. Then, create a shortcut to its launcher.exe with the extra plugin dir command line switch and see if it works. If it doesn't, try creating a shortcut to its opera.exe instead.

    If you get it to work, then maybe it's something with how the Opera Portable package you downloaded does things. Never messed with it myself.

    Also, I'm not sure the chrome extra-plugin-dir switch works in Opera like it does in Chrome. I'm also not sure if it works (in either Chrome or Opera) for PPAPI plug-ins. It might only work for NPAPI plug-ins.

    If all else fails, the PPAPI version of flash will probably have to be installed via admin via the flash installer on every computer you use portable Opera on. Hopefully that's not the case.

  • Also try --ppapi-flash-path= (and --ppapi-flash-version=insert_version_here).

  • Also try --ppapi-flash-path= (and --ppapi-flash-version=insert_version_here).

    Hi mate,
    Great effort, many thanks!

    I managed to combine your suggestions with the post below:
    https://forums.opera.com/post/52641

    Then i did such command line which did the trick!
    launcher.exe --ppapi-flash-path="C:\Users\username\Desktop\Opera 34 Portable\flashplugin\x86\pepflashplayer32_20_0_0_286.dll" --ppapi-flash-version="20.0.0.286"

    Edit: For some reason post editor doesn't seem to allow me to include "_" (underscore) char to the posts which i actually added to "pepflashplayer32_20_0_0_286.dll" (not shown on forum).
    It's now detecting Pepper (PPAPI) flash just fine, however Youtube videos are launched with HTML5 using Opera and no way to force Flash in Opera :(

    Thanks a lot, by the way!

  • Youtube videos are launched with HTML5 using Opera and no way to force Flash in Opera

    There are extensions that allow you to choose the player on Youtube. Magic Actions is one of them.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.