Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hi,

    Recently google in opera is broken. When attempting to edit the text in the search box after performing an initial search, the search box is unclickable. Sometimes, I managed to click it and this is what I get:

    Note that "test" was my initial keyword and the second "test" is me trying to add another phrase in the search box. The text becomes spread out and i cant hit enter.

    The other problem I found is that clicking on the 5th ot 6th search result doesn't take me to the webpage, instead it bring me back to the top.

    This is only hapenning recently. I am on Opera 34.0.2036.41, Win 10 (64 bit). I think it may have something to do with my screen resolution. It is 3200 x 1800 @ 150% DPI.

  • Unless you are speaking about the search box on the new tab page, we have been having this or a very similar issue on all browsers. We were able to resolve the issue by clicking the settings icon on a Google results page, then choose Search settings, then change ‘Google Instant predictions’ to ‘Never show Instant results’.

    I hope this helps.

  • Couldn't reproduce any of the issues here.

  • I have exactly the same problems as the original poster. Only difference is I am running Windows 7 SP1. Note google is not having this issue when I run Firefox. Its just when I run google in Opera.

  • does this situations happens on other pages?
    facebook, twitter, gmail...?!?
    because, I had similar problem...
    sometimes, for no reason, bookmarks bar and approximately 100 pixels on top of the page is unclickable, usually where search boxes are and some top bars/menues
    totally weird, it actually affects Opera UI (bookmarks bar)
    it's like some transparent elements is covering area under address bar (100-150 px height)

  • This only happens in Google search nothing else. This was not an issue a few weeks back. Opera updated itself and broke. I am sorry I couldn't tell you which version as I wasnt keeping track.

  • Seems to be working ok now.

  • Hello,

    I have EXACTLY the same problem as moolynx. I had Opera 34.0.2036.25 on Win 7, SP1 64 bit updated, Dell Latitude E6520. I reinstalled Opera to 34.0.2036.39. Unfortunately the problem remained.

    And it is no resolution problem - I normally have 1600x900, changed to 800x600, the same behaviour.

    Anyone help? Thanks.

  • Guys, this becomes even stranger: Opera behaves as I described above only on On British, Kiwi's, South African, Canadian, Polish versions it is perfectly fine. Can anyone explain this???

  • @cooljaca, I think you have nailed it. It happens on Opera and! I tried google in other countries its fine. search box causes text to spread and some links are unclickable. Please investigate.

  • Came to this forum for the first time because of this exact problem.
    Happens with Opera 34.0.2036.25, using, no problems with other browsers or other search engines. I've found that this happens on two different computers (one desktop pc and one laptop, both with Win 10 64 bit): as they have different screen resolutions, I don't think this is a problem with resolutions.

    No idea what to do about this

  • I have the exact same problem aswell.

    This is happening with Google Australia -

    All the other Google's work fine.

    Firefox and Edge are fine with Google Australia.

    I had a look at the old Opera browsers and found that up to Opera 25.0.1387.64 works fine and then 27.0.1689.54 stops working and has the issues with Google Australia.

    Opera beta 35 has the issues with Google Australia aswell.

    somewhere between 25.0.1387.64 and 27.0.1689.54 is where it stops working with Google Australia.

    Google Australia has recently stopped working, was working fine with Opera till about November December 2015.

  • @casey952, I can confirm that this happen sometime during November release. Please fix this, I find google to be unusable.

  • BUMP, still no fixes.

  • @moolynx I am confident that this issue is unrelated to Opera. As some have indicated, this issue occurs on the Australian version of Google only.

    Have you tried disabling the ‘Google Instant predictions’ feature? This has resolved this issue for us, which was present on several browsers.

    In addition, I have been unable to reproduce this issue on earlier. You might want to try to clear your browsing data.