Extension icons not shown in private mode

  • I'm running Opera in always in private mode (with switch -private)
    Unfortunately, since the latest version 33 the extension icons are no longer shown in the private Windows although they are enabled for private mode in extension manager. They extension icons are hidden by default.
    To get them back I have to go to extension manager and uncheck "Hide from toolbar" and then check it again for each individual extension. This solves the problem temporarily but for the current session only. After closing Opera and restarting it the icons are gone again.

    Looks like the appropriate settings are not properly saved ??
    Any ideas?

    Environment:
    Opera 33.0.1990.58
    Windows 7-64

  • I have the exact same problem. All the extensions (4 in total) are hidden in the taskbar, so theres no way of knowing for eample how many trackers are blocked at the moment or if the extension is working at all.

    Opera 33.0.1990.115 Windows 7 x64

  • It's not working in the latest version and it's not working the the beta. Someone fouled something up and is too stupid to realize it.

  • Or, most probably, it's just a non top priority issue.

    Btw, was it reported?

  • I am having the same problem. Please fix or provide workaround.

  • I am unable to replicate this issue with Adblock Plus on Opera 34.0.2036.25. You might have to update your browser.

  • Try:

    1. install an extension (make sure it is allowed in private mode)
    2. quit opera
    3. run opera in private mode using -private switch
    4. Extension icon is missing.
  • Thank you for the additional information. I am indeed able to replicate this when starting Opera with the -private flag. I hope the developers take notice and resolve this issue for those who are dependent on the -private flag.

  • This issue has not been fixed for at least half a year.
    It's been reported constantly for at least half a year.
    It's been posted in these forums for at least half a year.

    Do you developers even care? I don't want more themes. I want a working browser. Do you?

  • Is it posted in the bug tracker? Forums are all well and good but this isn't exactly where the devs spend their time.

  • Is it posted in the bug tracker?

    It's been reported constantly for at least half a year.

  • Is it posted in the bug tracker?

    It's been reported constantly for at least half a year.

    It probably has (very) low priority as it doesn't affect that many users. And also it doesn't happen when opening Opera in the default way.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.