Rear speaker support

  • Hi, I've got a surround sound setup and in the old Opera the rear speakers would activate to mirror the sounds of the front speakers, which I found quite nice, but I can't seem to do the same in the new Opera. Is there any way to accomplish this or should I just stick to the old version?

    I'm running Windows 10 and I heard about a trick about adding " --force-wave-audio" at the end of the shortcut directory but it didn't seem to work for me.

  • Thanks a lot for the issue report. It will be passed for further investigation to the appropriate team.

  • Will I get some kind of notification of the issue is resolved or addressed, like by email or something?

  • Currently Opera uses your Windows speaker settings for 'speaker fill'. So if you have a stereo audio source it will only play on your front speakers if thats what Windows is set to do. If Windows is set to clone the signal to your rear speakers than that is what Opera will do. The location of this setting can very depending on your sound hardware but here is where I find it on my machine: Right click speaker icon in notification area > Playback devices > Double click your playback device > Enhancements > Enable speaker fill. This will not effect true surround playback. If you play a 5.1 signal with this setting it will sound just like it should.

    Here is a way to test 5.1 playback in Opera:
    https://www2.iis.fraunhofer.de/AAC/multichannel.html

  • What Opera is supposed to do and what it actually does can sometimes be two completely different things

    Youtube videos for instance are in stereo but should output to all channels but they don't, now if i download that youtube video as an .MP4 and play it locally on say MPC-HC for instance all speakers output audio

    this only started happen by the way from version 25 and upwards bellow that and everything worked as it should do with audio outputting to all speakers it happens on both my creative X-fi card and my on-board realtek atleast with the Xfi I can force output to all channels

  • play it locally on say MPC-HC for instance all speakers output audio

    Right, cause Media Player Classic does the speaker fill for you.

    this only started happen by the way from version 25 and upwards

    Welp, I don't know what to say there. I don't think I started using the new Opera until after then (whenever they added Bookmarks) and I I wouldn't have noticed anyway because I have speaker fill turned on. That said, when I turn speaker fill off YouTube is only stereo and when I turn it on it goes to all speakers, so I know it works.

    Based on posts I've seen about Chrome I'm pretty sure its a thing with the Chromium code and not just Opera. There are tons of people complaining about YouTube suddenly not filling their back speakers from awhile back.

  • Currently Opera uses your Windows speaker settings for 'speaker fill'. So if you have a stereo audio source it will only play on your front speakers if thats what Windows is set to do. If Windows is set to clone the signal to your rear speakers than that is what Opera will do. The location of this setting can very depending on your sound hardware but here is where I find it on my machine: Right click speaker icon in notification area > Playback devices > Double click your playback device > Enhancements > Enable speaker fill. This will not effect true surround playback. If you play a 5.1 signal with this setting it will sound just like it should.
    Here is a way to test 5.1 playback in Opera:
    https://www2.iis.fraunhofer.de/AAC/multichannel.html

    I am not very technically minded but if it's a setting with Windows then how come Opera 1 does it and Opera 2 can't? Is the speaker fill setting automatic for Opera 1 only or something like that? (I couldn't find the speaker fill option for my audio either)

  • Because Opera 1 (Presto renderer) and Opera 2 (Chromium renderer) are completely different programs. They share no code.

  • Will I get some kind of notification of the issue is resolved or addressed, like by email or something?

    Nope, you will have to check in the changelogs.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.