How to disable Auto-Update in the MacOS version, for those who need that.

  • I refuse to allow software to update without my express permission, and so I have been forced to get creative since so many software companies feel the need to ignore my wishes on the matter... I have no interest in beta-testing features, nor do I want my personal space (my computer) invaded by rogue installers.

    Since I was informed that my reply was to a Windows thread, I will post a new thread specifying MacOS for those like myself.

    I found a way to disable the auto-update feature in the MacOS version of Opera.

    If you wish to do so follow these steps:

    1] Go to the Applications folder and click on the while simultaneously pressing the "Control" key you will get a pop up menu. From that menu, select "Show Package Contents" which should be your second option.

    2] Then a window opens with a folder that says "Contents." Open that and then you will see a bunch of files and folders.

    3] Open the folder that is labeled "MacOS." Inside you should find a set of "exec" files. There is one called "opera_autoupdate"

    4] Rename that to "opera_autoopdate," (just one letter wrong so you can change it back if so needed) and then closed everything and launched Opera as usual.

    When I opened the opera://about page the app said it was checking for updates for about 5 minutes then displayed "An error occurred while checking for updates."

    The app behaves normally in every other way.

    So apparently I accidentally found the way to disable updates on the MacOS version of Opera. I was just fooling around and didn't think it would work, but it does.

    I am sharing this in the hope it will help others.

  • You can also set the environment variable OPERA_AUTOUPDATE_DISABLED. This works on all platforms.

    For Opera 32 and newer, you can use a global Apple preference. From Terminal, enter one of these commands:

    For stable:
    defaults write com.operasoftware.Opera OPDisableAutoUpdate true

    For beta:
    defaults write com.operasoftware.OperaNext OPDisableAutoUpdate true

    For developer:
    defaults write com.operasoftware.OperaDeveloper OPDisableAutoUpdate true

  • pressing the "Control" key you will get a pop up menu. From that menu, select "Show Package Contents" which should be your second option.

    Yeeeessss! Thank you. Looked just about everywhere else for the autoupdate thing. Incredibly annoying when you're working on a mobile hotspot and it downloads the update, then asks for your password to install it. If you don't give your password, guess what? It downloads again!

Log in to reply

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.