@font-face not working

  • I am using 64-bit Opera 32.0.1948.4 on Windows 7. I have been unable to get @font-face to work. It works on IE, Chrome, Firefox, Safari and Opera 12.15. I have tried all sorts of variations, all of which work on the other browsers but not on Opera. I have tried single vs double quotes. I have tried different types of font files (eot, ttf, woff). I have tried omitting the "format" clause. I have tried an absolute vs relative url. Nothing works on Opera 32 and everything works elsewhere (barring unsupported font types for specific browsers). Here is a sample page that is failing.

    <!DOCTYPE html>
    <html>
       <head>
          <title>JavaScript test page</title>
          <style type="text/css">
             @font-face
                {
                font-family:   "OutlineTest";
                font-style:    normal;
                font-weight:   normal;
                font-stretch:  normal;
                unicode-range: u+0030-0039,u+0041-005a,u+0061-007a;
                src:           url("Fonts/OutlineTest.woff") format("woff");
                }
             .outline
                {
                font-family: "OutlineTest";
                font-size:   24pt;
                }
             td
                {
                font-size: 16pt;
                }
             </style>
          </head>
       <body>
          <table>
             <tbody>
                <tr><td><span class=outline>&#x30;</span></td></tr>
                </tbody>
             </table>
          </body>
       </html>
  • Can you share the link where you download Opera developer 64 bits for Windows?

  • If he has such a link he would not be allowed to share it. More likely he meant 64-bit Windows.

  • I uninstalled the beta version during my testing. I reinstalled it, and I see that I was misreading the "about" page. The beta version is still 32-bits. Opera 12.15 does have both 32-bit and 64-bit versions, so I just assumed that was true for the current development branch as well. I have more browsers and virtual machines for testing than I can remember - sorry for the confusion.

    My other post that was closed was a near duplicate of this one (I wasn't sure of the correct place to post this issue). The only difference is that I had additionally tested against the stable version and @font-face works for the stable version.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.