If you go to opera://plugins what does it say is installed? If it lists Flash, does it say NPAPI or PPAPI? Opera uses the PPAPI version, but will usually list both. If you don't have the PPAPI version, then go to the Flash download page while using Opera and it should give you the correct version.