Disable gestures, or be more careful. You are accidentally doing the New tab gesture (hold right button, drag mouse downwards on screen, then release button) when trying to right-click, so you either need to be more careful not to move the mouse or disable gestures completely (in Settings > Browser, in the section Shortcuts).